Ford Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,354 Posts
Discussion Starter #1
Went to new England dragway today and ran into a few issues one of which was my fault.forgot my wheel spacers so that my sve drag wheels can clear the caliper banjo bolt.headed to the lanes and did not notice any noise till i was on my first pass.car felt like it had a drag on it and turn out the rim was draging on the brake caliper.another issue was my alternator plug came loose and my voltage drop a lot.still manage a [email protected] mph.very disappointing day,weather was in the high 80s and very humid.hoping for some better weather in a couple weeks.
 

·
Registered
Joined
·
676 Posts
You certainly have a lot of potential with those power numbers. Can't tell from your sig if it's a stick car or auto. You have the power to run very low 10's. If it is a stick car, nothing will hurt you more than those 18" drag radials. Stick car.......15" stiffwall slick ftw. Can't run a low ET without an acceptable 60'. With your power, hopefully around a 1.3xx-1.4xx.
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #3
Bamabox,
It's a viper t56 with the 2.66 first gear.was on a new set of mt 26*10*15 et drags stiff side wall.launched at 4k rpms resulting in a lack luster 1.73 60ft.
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #4
Weather was hot and humid in the low 90s.
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #6
60 ft was 1.73.like i stated in my original post had some issues on that my only pass.
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #8
Mph was 126 but not sure if adding 4 gallons of c16 to 93 octance had an affect on my horsepower as the car was tune on 93 with water methanol.
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #9
Also running out of gear with 4.10s and a 26 inch tire.going to try a 28 next time out
 

·
Registered
Joined
·
2,354 Posts
Discussion Starter #10
Update.
Went back to the track after sorting out my previous issues and ran into some more issues with a newly installed n2mb wotbox blowing the fuse in my kenny bell boost a spark.car was breaking up at the top of every gear.only manage a [email protected] to rewire a few things and it should be good to go.
 
1 - 10 of 10 Posts
Top