Ford Mustang Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2,548 Posts
Discussion Starter #1
Well I finally got my car to the track for a couple passes, only got 2 in before it rained.

1st - let off before the the finish line, full exhaust, launched off the 2 step at 2500 rpm

60 - 1.725
330 - 4.857
1/8 - 7.449 @ 94.80 mph
990 - 9.680
1/4 - 11.599 @ 113.63

2nd - opened up dumps, launched off the 2 step at 2700 rpm

60 - 1.702
330 - 4.768
1/8 - 7.332 @ 95.68 mph
990 - 9.545
1/4 - 11.424 @ 119.12

The car needs to be tuned and I know it is on the rich side. On the last pass I was going to data log it but when I got up in the lanes the laptop was dead and I forgot to bring up the invertor from the pit so....
I'm sure it has more in it, I saw 16 psi on the boost gauge. On a positve note it ran nice and straight, very easy to drive.

So what do you think? What should I be doing? Or need to do?
 

·
Registered
Joined
·
1,305 Posts
Yup, getting the 60' into the high 1.4's or low 1.5's and you will probably get in the 10's. For every tenth you pick up in the 60, you get 2 tenths in the quarter.

Keep raising the 2 step RPM untill it starts overpowering the tires, and then start playing with the suspension.
 

·
Registered
Joined
·
4,361 Posts
wow, just removing the restrictions of the tailpipes plus adding 200 rpm on the launch you gained 6mph on the top end, thats great

it looks like you have alot of potential..
 

·
Registered
Joined
·
2,548 Posts
Discussion Starter #9
I was pretty happy with the 60 but ya I'm going to bring up the launch rpm some more and see what happens. It's my first time at the track with an auto so I'm still figuring it out. Also the first time I've been to the track with it for 3 years but I'll be going again soon. ITS FUN! LOL
I did get a look when they gave me the slip (no cage). The guy that ran beside me had a 89 Mustang and was pretty surprized I passed him, his was all done up for racing as it was a track only car. Came over after and congratulated me, that was nice.
 

·
Registered
Joined
·
2,548 Posts
Discussion Starter #10

·
Registered
Joined
·
1,666 Posts
Are you bringing the 2-step up against a footbrake or do you have a transbrake? Any tire spin? If your foot braking, your more than likely "loading" the suspension which will probably hurt your 60's. My 60's aren't the greatest (1.59's), but they aren't bad for no transbrake. I've had the best luck launching just off idle, converter flashes better/higher.
 

·
Registered
Joined
·
2,548 Posts
Discussion Starter #13
Are you bringing the 2-step up against a footbrake or do you have a transbrake? Any tire spin? If your foot braking, your more than likely "loading" the suspension which will probably hurt your 60's. My 60's aren't the greatest (1.59's), but they aren't bad for no transbrake. I've had the best luck launching just off idle, converter flashes better/higher.
I'm using a second line lock so ya same as foot brake. My stall is a 3500 of I figure it would then flash from the 2500 to 3500 but I'm going to try it lower and higher to see what works best. Its not spinning at all, starting to think a trans brake would be the better way to go for the track but probably better on parts doing it the same way I am as eveything is loaded up.
 
1 - 13 of 13 Posts
Top