Ford Mustang Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter #1
I have noticed that my wastegate is letting exhaust by at idle. The car still revs and blows off though pretty well so it does leave some pressure. I have a small spring in the gate and a boost controller turned all the way down.

Could the boost controller have anything to do with the wastegate being open at idle? The top of the wastegate is vented to the atmosphere and the side port runs back to the Boost controller as precision recommends.
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
There is really no reason for it to be open when you are at idle, I have trouble believing you could have that much back pressure at idle unless you have a tiny turbo.

Is it new or does it have a lot of abuse on it? I would take it apart and check the valve stem, valve and seat to make sure it is moving freely and nothing is hanging it up.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #3
It is a 70/68 turbo with very little use on it. The wastegate is the same. I have not taken it off yet but I can def. feel exhaust pressure from the dump dump, and I can hear it a bit. When I take the car out it seems to get into boost pretty well but maybe it is not. I have gotten it to 1-2lbs with very light throttle because the car is not tuned. I just want to make sure it is good before I get the car tuned.
 

·
Registered
Joined
·
461 Posts
Don't do it. I just messed my car up yesterday driving it untuned. So this weekends project replace the head gaskets and hope I didn't vent the block. Gl
 

·
Registered
Joined
·
2,531 Posts
sounds like the valve seat is not in place...it should be silent until you're coming into boost...
 

·
Registered
Joined
·
312 Posts
Discussion Starter #8
Multiple tuners have told me its ok to drive without a tune as long as you stay out of boost which I have done. Fuel pressure and AFR are good I am not sure how anything could happen to it I mean I need to know everything works before taking it to the tuner right?
 

·
Registered
Joined
·
3,335 Posts
what happens is some ppl can't resist getting the car into boost while they wait for a tune so they roll the dice and come up with snake eyes.
 

·
Registered
Joined
·
2,531 Posts
I drove my car 400 miles from Sacramento to LA with no tune in it and then made 689RW the next day....

your car should be able to be driven with no tune...
 

·
Registered
Joined
·
3,335 Posts

·
Registered
Joined
·
3,335 Posts
So should the wastegate not have any exhaust coming out of the little pipe at idle?
no...at least mine doesn't.
the wg should be sealed until the installed spring starts to reach its activation point.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #16
I think I figured out what the issue was. I had only the tiny 2-3lb spring in it. Any of you that have felt this spring know how weak it is. I don't think it had enough umph to keep it closed 100% at idle. I put the next strongest spring in it but still have the manual boost controller for it. I put it back on tonight so we will see if that was the problem tomorrow when I start it. Hopefully so!
 

·
Registered
Joined
·
3,335 Posts
I think I figured out what the issue was. I had only the tiny 2-3lb spring in it. Any of you that have felt this spring know how weak it is. I don't think it had enough umph to keep it closed 100% at idle. I put the next strongest spring in it but still have the manual boost controller for it. I put it back on tonight so we will see if that was the problem tomorrow when I start it. Hopefully so!
yes...this is more than likely your issue as the 2-3 lb springs are not supposed to be used by themselves.
 

·
Registered
Joined
·
206 Posts
I took mine off and it looks like the valve doesn't come down enough! I took it apart and everything else looks ok. I'm not sure if I can adjust the depth with the set screws or if I should grind the base down so the ring sits tighter to the valve! What do you guys think?
 

·
Registered
Joined
·
206 Posts
I adjusted the valve by loosening the set screws and moving the valve down further till it hit the metal ring! I will put it back on tomorrow and hopefully will be all good!!!
 
1 - 20 of 24 Posts
Top