Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Need constructive suggestions on troubleshooting a rich condition. Wideband says 9.1 afr at idle and the thing barely runs.
specs are:
97 convert gt 182K miles
Vortech V2 with a 3.33 pulley
Aeromotive 340lph pump
42# Bosch injectors
90mm lightning MAF
CXRacing intercooler with apparently a junk bov
Delta Force Sniper software
Pype bomb M80 exhaust
New NGK TR55 plugs gapped to .032"
BOV recirculated
MAF is draw through Vortech location
Vortech inlet pipe
IAT 'stock' Vortech location pre blower.
New fuel filter

Prior to the blower install the car ran great. I did a test tune pre blower. I installed the exhaust and made a hard pass on the freeway. I downloaded a tune for the exhaust and 91 octane (which I always use) and repeated the freeway run. After the tune it ran smoother at idle and pulled harder on the top end.

It seemed like just after the blower install and subsequent tune that the car ran ok but then degraded. Early this week I'll be checking the fuel pressure. I also plan on pulling spark plug wires to see if there are any ignition problems.

Any other suggestions? I purchased the software from Willie at Dirtydirty racing. He's been very helpful but I wanted to get more 'eyes on the problem'.
Thanks in advance,
Tony
P.S. Read Victor Maynards (I hope I got that right) thread, very informative although it looks like I've got a ways to got before this thing is dialed in.
 

·
Registered
Joined
·
1,002 Posts
If you have a large vac leak in the intake stream it will cause a rich condition, but I dont think quite that rich.
I would test those injectors to see if one is stuck open. And like Indy said , check narrow bands to see if even working and what commanding
 

·
Registered
Joined
·
21,872 Posts
an unmetered air leak will cause a lean condition

the 02s will report lean

the ecm will add fuel, if it cannot add more, it will still be lean

If they 02s are shorted or dead

The ecm will see them as reporting lean, and add more fuel

Then the wb band will see rich

This assumes commanded is 14.6
 

·
Registered
Joined
·
276 Posts
Not sure what the Delta Sniper can do but I assume it is similar to the rest of the Ford EEC tuning software out there. I would make sure the MAF curve is correct and commanded AF is correct. Make sure there isn't anything stupid in the ACT (IAT) or ECT correction tables.

It's been said already but check for unmetered air. Plugs need to be replaced because they are likely fouled by now and that will just make the problem harder to fix. Might need a couple of sets if you don't figure it out quickly.

Your combo has been successfully used many times before. Shouldn't be too difficult to get sorted out. Good luck.
 
1 - 6 of 6 Posts
Top