Ford Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
i have a dart 347. i have made 640hp and 745tq w a masterpower t70 turbo. i upgraded recently to a new comp 80mm turbo and i cant even seem to break 600hp most power numbers being in the low 500s. im looking for ideas bc i am stumped. normal things like heads being maxed out cant flow anymore w.e restrictive exhaust all would be things id agree w if i hadnt already made the power with an even smaller turbo. like i said im outta ideas so please fire away
 

·
Registered
Joined
·
4,154 Posts
I'm not familiar with turbo sizing but that seems like a really big turbo. How much boost was it registering, what rpm are you turning?
WG's working correctly?

ks
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
comp 8079.......i have an electronic cutout i can even dump the exhaust if backpressure was the issue. only picked up about 10hp usually picks up about 50+, rpm was the same right around 4000rpm was were we were comparing and airfuel was on at 11.2-11.7 but the power was just down so much and it seems lazy. wastegate boost was set at 14psi and it was making around 10 turning the boost up to 22psi the power picked up but not sustantially i think it was still only like 560hp with me adding meth to it too!!!! like i said im lost. before i used to make about 560 w cut out closed then opening would add 50+, then adding boost and meth the power would pick up more and more and now its nothing
 

·
Registered
Joined
·
1,124 Posts
sounds like yall forgot to put the spout plug back in

definitely an ignition timing issue

Of the several hundred sbf's ive tuned over the years not a single one had ever made less than 700rwhp with 20+ lbs of boost... definitely a timing issue
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
spout was in and timing was checked and varified. we even held a timing light on it to see where it was at while making a pull on the dyno. dead on. also added 4 degrees to 24 with the meth and it picked up quick a bit but still extremely low. also i have moates quarterhorse with a laptop so i can digitally see what the timing is at. the owner of the dyno suggested its my cam holding back the power but i dont see how thats feasable it should have still at least made as much as before
 

·
Registered
Joined
·
162 Posts
With the new turbo vs old, what are the A/R, intake housing size, exhaust housing size, and so on. It sounds like you just put a snail on there that is too big for the combo. It isn't pushing enough air. Either that or the exhaust turbine is too big for what your exhaust is putting out so it is spinning slow. Or a combination of both.
 
  • Like
Reactions: TomR

·
Registered
Joined
·
4,970 Posts
With the new turbo vs old, what are the A/R, intake housing size, exhaust housing size, and so on. It sounds like you just put a snail on there that is too big for the combo. It isn't pushing enough air. Either that or the exhaust turbine is too big for what your exhaust is putting out so it is spinning slow. Or a combination of both.
^^^^ that

Also, how do all the logged reading like air temp compare? What all did you change? Just the turbo only?

What is the whole combo???
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
i changed the turbo bc the old turbo lost an oil seal and i upgraded it bc it was at the point of nearing its maxed out and i still have room to grow. i think i may be on to something today though i found 3 cylinders all on drives side only having 60psi. i tried a leakdown and couldnt find it to be leaking anywhere even after adding like 100psi nothing in intake exhaust cooling system or crankcase that i could really hear for it to be a 100+ psi loss. still kinda stumped but at least got a place to start and at this point i think the turbo could be ruled out lol!!
 

·
Registered
Joined
·
2,964 Posts
Idk, I think that turbo is to big and not being pushed by your setup to make it really work to see good numbers. Your old turbo was matched better for your combo so it performed better in your rpm band. This one is so big it's just not being pushed so it's not performing and your seeing low numbers
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
id agree w you but its really not that much bigger on the exhaust side 10mm on compressor and 8mm on the exhaust side. im leaking compression somewhere on cylinders 1,2, and 4 so i think the turbo is off the hook for now. i just havent been able to find where its leaking yet leakdown test didnt show anything substantial like it should. im gonna try a wet compression test. check results and then check valve lift as a last ditch effort to see if the cam is flattening out before having to pull the heads
 

·
Registered
Joined
·
408 Posts
Ever figure out issue? Just curious.
 
1 - 14 of 14 Posts
Top