Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
418 Posts
Discussion Starter #1
does anyone know what the cause is, its driving me crazy. my stock setup never made a noise, but i installed the king cobra pressure plate, hays disk, and timken bearing(from autozone), and it won't stop squeeling. tried adjusting the cable, but it just squeels. does this happen with all clutch installs, or just the king cobra pressure plate? i've noticed that the new clutch catches at the very top of the pedal, which i don't like. i'm thinking of getting a different setup. any opinions/ideas/experiences?
 

·
Registered
Joined
·
394 Posts
i know ford a SSM (special service message) on throw out bearing squeal...dont know if they just replaced it or updated it with a better part....

one more thing....did you put some wheel bearing grease on the shaf that the throw out bearing will be traveling?

one more note...are you still using the stock clutch quadrant? if so...you have to reset the adjustable clutch....after doing your clutch....give a tug on your clutch pedal....pull it up...and youll feel a pop....then everything will self adjust
 

·
Registered
Joined
·
418 Posts
Discussion Starter #3
no, i have a adjustable unit. i did grease the input shaft. all i know is it is driving me crazy
 

·
Registered
Joined
·
285 Posts
Same squeel in my 01 with stock clutch. Dealer said they did not here anything so they did not fix it. It's random, but very annoying. Every stop I make I just put the car in neutal and let the clutch out so people don't stare at me. I am going to wait til it gets real bad and then the dealer can fix it.
 

·
Registered
Joined
·
418 Posts
Discussion Starter #5
mine does it when the clutch is out, i have to hold the clutch in to stop it
 
1 - 6 of 6 Posts
Top