Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
i made a thread about this around a month ago, but i havent really had time to work on it lately with my job keeping me busy.
Basically its so bad that i dont feel comfortable running it to try and diagnose the issue. I changed the plugs, they were just about dripping with fuel, my oil was getting contaminated with gas it was so bad, so i changed that(hopefully before any damage has taken place) so now i dont know where to go from here.
its running this bad even shortly after startup, so i dont think its my o2's. Maybe my MAF? i have not checked to see where the voltage is at during idle.
any single sensor that if bad, could throw it off that much dumping huge amounts of fuel? I'm going out of my mind here and almost no time to work on it so i have to have some sort of a game plan together before i start pulling things apart :)
 

·
Registered
Joined
·
465 Posts
Have you checked to make sure your fuel pressure regulator diaphragm isn't torn letting fuel get sucked into the intake?

Checked for fuel injectors leaking down/stuck open?

The coolant temp sensor can cause extra fuel to be added, but it shouldn't add THAT much fuel if it was faulty.

What maf is on the car?

Will
 

·
Registered
Joined
·
468 Posts
Discussion Starter #4
I'm running a 3" protube and 42's that are being tuned using a EECtuner. i dont think its the injectors sticking because when i changed the plugs they were all fouled with gas.
i was thinkng maybe the ECT as well, but i agree i dont think it would dump that much extra fuel. the FPR is something i havent checked yet but will do so today.

thanks for the advice so far, any other ideas?
 
1 - 5 of 5 Posts
Top