Ford Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter #1
Well guys, I bought two new 15x10 pro stars...with the correct 6.5 BS and I threw one on the car quickly and it seems to not fit AT ALL, unlike many of the people on here with 94's like mine.

It seems to be hitting the e brake cable and control arm??

any thoughts..I'm nervous. lol, why did I try and be the man and get the 10'' wheels and not the 8's!!!! hahahahah

Chris
 

·
PMS Tuning Forum Moderator
Joined
·
3,478 Posts
They should fit but if they are hitting things just buy some inexpensive Moroso wheel spacers. Space the wheel out just enough to clear those items.
 

·
Registered
Joined
·
1,240 Posts
Have faith they will fit. If you would like I have some 15x8 with 4.5 backspace and want ewxactly what you have. Let me know if you wanna work something out.
 

·
Corral Charter Member
Joined
·
3,746 Posts
I've had 10" wheels hit the ebrake cable before. You can usually reroute the cable out of the way.

I've not seen them hit control arms before. Do you have stock control arms? You're sure it isn't the quad shock?

steve
 

·
Registered
Joined
·
10,681 Posts
ill trade ya some 15x8s brand new :) lol
 

·
Registered
Joined
·
1,742 Posts
do you have tires mounted on them? did you take the car off of the jack and or jackstands to see hat they are touching? sounds odd for an sn95 with 6.5 bs to hit anything. e brake cable is an easy fix but the lca sounds off.
 

·
Registered
Joined
·
617 Posts
6.5 bs is 6.5 bs no matter what size the rim is. are you using a stock sn95 rear or a older fox rear? you probably need 5.5 bs
 

·
Registered
Joined
·
1,586 Posts
6.5 bs is 6.5 bs no matter what size the rim is. are you using a stock sn95 rear or a older fox rear? you probably need 5.5 bs
Well what if the wrong wheels were sent?? :confused: And a 5.5 BS would make it ghetto, and stick way the f- out:barf:
 

·
Registered
Joined
·
510 Posts
I had 15x10 Prostars with 6.5 bs and they fit fine. The tire did hit the ebrake cable but I just bent the bracket a little it all was fine. It was not even close to the control arm. It was very close to the quad shock though.
 

·
Registered
Joined
·
289 Posts
I'm with the other yellow guy. My 15x10s with 6.5" BS were fine, didn't even hit the ebrake. Just curious, what tires are you running?
 

·
Registered
Joined
·
617 Posts
well maybe the wrong wheels were sent, or maybe it has a different 8.8 in it. and a 5.5 bs fits fine, its what i use for my 29x10.5 tires and they tuck under fine, but i also have a 90 8.8 housing. so hence the q of what rear does he have.
 

·
Registered
Joined
·
1,818 Posts
I run 15x10's on my '95 GT w/6.5 BS and it fits perferct, even with 28x12.5 ET Streets. Did bend the e-brake bracket down a little and I don't run quadra shocks.
 

·
Registered
Joined
·
510 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter #15
well, i got em to fit... just bent the ebrake cable a bit on the pass. side and flipped the quad shocks around. Even my 28x11.5 fit with quad shocks, but then I took em off completely at the track. Thanks for all your help guys and suggestions. I'm gonna make another post now on my poor poor drag racing this weekend....thats a whole different story.

please look for it!

Chris
 
1 - 15 of 15 Posts
Top