Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
hey everyone, i have a 95 gt alm heads tfs intake 50# injectors matched to blow through pmas walbro 255 adjustable fpr, stock pcm. it idles at 11.3-11.8 afr on my WB, and driving around it goes way lean like 17.0. if my maf curve was wrong would it do that? should be lean or rich the hole way right? i have tried clocking the maf no change, also had fuel pressure from 30# up to 50# turning it up only helps a little under load brings it down to about 14.4 wot. im fuel pressure is not falling off. any help would be great. thanks.
 

·
Registered
Joined
·
193 Posts
Do you have a boost reference fuel pressure regulator? Is it working correctly? It sounds like it isn't. It should pull fuel pressure out under vacuum and raise it with boost.
 

·
Registered
Joined
·
120 Posts
Discussion Starter #3
no its not boost ref but it is working right i set it at 50# NO vac, and hooked the vac up it pulls it down to like 42 ish, and under load/wot/boost it goes back to 50#
 

·
Registered
Joined
·
295 Posts
If you dont have some form of a chip or stand alone for a tune...I dont think it will ever be correct.
 

·
Registered
Joined
·
216 Posts
You should get a boost reference FPR, this will help clear up some of the problem. The other part of you problem is TIMING. How are you controlling the timing? Are you locking it to 18 or are you running a chip, PMS, ect?
 

·
Registered
Joined
·
193 Posts
no its not boost ref but it is working right i set it at 50# NO vac, and hooked the vac up it pulls it down to like 42 ish, and under load/wot/boost it goes back to 50#
You need a boost referenced regulator. 50 is too high for a base. With a boost referenced reg. you would set it around 42 with the spout out vacuum would pull it down to 36 and 10psi would bring it back up to 52. That should give you a starting point. We have ran several cars like this some with locked timing some with a btm and they all worked well.
 

·
Registered
Joined
·
120 Posts
Discussion Starter #8
yes timing is locked at 18-20 also tried low boost like 3-4# with the timing set to 8* then put the sput connector in, also i have had my fuel pressure all over tired it from 30 with vac to 45 with vac and a few places in between. and heres whats got me lost this car ran great for a week or two afr was nice at idle and great in boost pulled like crazy, then one day all this happened.
 
1 - 8 of 8 Posts
Top