Ford Mustang Forums banner

1 - 20 of 56 Posts

·
Formerly eades5.0
Joined
·
4,716 Posts
Discussion Starter #1 (Edited)
1st dyno pull the shaft snapped in half destroying the turbo.
I had about a hour or so of run time on the new turbo, and made 5-6psi a few times on the street being careful waiting for my tune (not wot pulls)

Tuner got my idle right, and I had a tip in issue with the MPT70, so we put it on the transbake 2-3 times getting that ironed out. It made 6psi on the brake.
At this point the turbo was great, just hadnt had a real wot pull.

Put it on the dyno, 1st pull KABOOM by 3000rpm..as soon as it spooled under load.
I pulled the filter off, only to see purty pieces of billet falling out everywhere.
Had oil in the turbo when i pulled it apart, and the feed pumps plenty into a gatorade bottle so it was not starved for oil. The shaft snapped clean in half.

Turbo is destroyed

Hope they back their warrenty


Balance issue, bearings not in toelrances, not built right?

WTF happened?

Luckily nothing in the motor, but i will buy a new intercooler just because it has a good bit of billet in it. I never realized what a good filter a intercooler is.

I am so upset guys, stomach all in nots.

My brand new 76hpsh is junk.
 

·
Registered
Joined
·
200 Posts
Dammit man- that seriously sucks! I've heard lots of good things about precision so hopefully a warranty claim will be a smooth process.

Never heard of one failing catasrophically without something being injested- was this a double ball bearing?
 

·
Formerly eades5.0
Joined
·
4,716 Posts
Discussion Starter #6
Dammit man- that seriously sucks! I've heard lots of good things about precision so hopefully a warranty claim will be a smooth process.

Never heard of one failing catasrophically without something being injested- was this a double ball bearing?
Journal bearing, had a filter on it also.
 

·
Registered
Joined
·
608 Posts
Sorry to hear, that was probably a beautiful piece. Crazy how far u got with the cheaper MP and this happens. What did the tuner have to say about it.
 

·
Formerly eades5.0
Joined
·
4,716 Posts
Discussion Starter #9
Everyone said it had to be a bad turbo, and they have never seen that. How long have these billet units been out, like a year? I was told garrett made the wheels in the gts turbos and precision now makes these billet wheels in house and the name changed from gts to hpsh.

I run a cheap MP for over 4 years no issues, I buy a real nice billet precision it blows up on the 1st pull before 3k.
LOL

Has to be just bad luck
 

·
Registered
Joined
·
1,006 Posts
It's bad luck. It happens. I've been flogging the #### out of two of them without missing a beat. The new billet stuff is no joke. I'm on the verge of breaking everything and the turbos aren't working yet lol.
 

·
Registered
Joined
·
2,983 Posts
wow man thats crazy. The cost of that turbo down the drain would kill me. I sure hope they take care of you.
 

·
Formerly eades5.0
Joined
·
4,716 Posts
Discussion Starter #19
I think a guy on the turboforums had a billet wheeled 78 break on him a year ago.Cant seem to find the link though.
Jim
I have searched and not found anything either. I have spoke to a few people that think they have read about a 67 billet, but nothing I can find. This makes me feel much better, like it is more of a isolated issue with my paticular turbo.
Maybe I will go billet again...
 
1 - 20 of 56 Posts
Top