Ford Mustang Forums banner

1 - 20 of 35 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Hi guys have friend I stall turbo turn on is throwing to much fuel he took out plugs came out white thought he needed tune order a burn chip feo
On 3 got it yesterday put on same problem it's shooting fuel from exhaust co
Compressor any help???
 

·
Registered
Joined
·
2,531 Posts
God DAMN!!!!!!
 

·
Registered
Joined
·
1,536 Posts
God DAMN!!!!!!
Great post :rolleyes:

Hi guys have friend I stall turbo turn on is throwing to much fuel he took out plugs came out white thought he needed tune order a burn chip feo
On 3 got it yesterday put on same problem it's shooting fuel from exhaust co
Compressor any help???
Is english not your first language? Posting from your phone? Add some grammar to the mix....will make it much easier to read.



How is the timing? That can cause flames to come out of the exhaust. Get a timing light on it....
 

·
Registered
Joined
·
104 Posts
Discussion Starter #9
frend of mine just installed a on3 70mm turbo on his 93 cobra.after he finished it started it up but it was pushing to much fuel. he took out the sparkplugs and they were all white i guess full of fuel. he thought maybe it needed a tune for it to run ok since the upgrade of injectors fuel pump. so he called on3 and they told him he needed a chip burned so he order it, yesterday he put it on and same thing had fuel coming out of the compressor and tailpipes. hes thinking maybe pinch return line on fuel pump??? any advise
 

·
Registered
Joined
·
2,531 Posts
frend of mine just installed a on3 70mm turbo on his 93 cobra.after he finished it started it up but it was pushing to much fuel. he took out the sparkplugs and they were all white i guess full of fuel. he thought maybe it needed a tune for it to run ok since the upgrade of injectors fuel pump. so he called on3 and they told him he needed a chip burned so he order it, yesterday he put it on and same thing had fuel coming out of the compressor and tailpipes. hes thinking maybe pinch return line on fuel pump??? any advise
White = lean BTW...

also could be bad FPR and bad tune wouldn't cause the fuel issue....
 

·
Registered
Joined
·
104 Posts
Discussion Starter #11
Ok but white not as in just the tip I mean as in the whole spark plug looked like if it had powder
 

·
Registered
Joined
·
2,531 Posts
Ok but white not as in just the tip I mean as in the whole spark plug looked like if it had powder

correct...a fouled plug is wet and black..


 

·
Registered
Joined
·
444 Posts
still what is the timeing at ? what is your fuel pressure set at ? your custom chip may be for more or less boost than your runing and more or less fuel pressure . as far as i knew on3 has a custom chip to get u to a tuner to burn a proper tune for the car which sounds like u need
 

·
Registered
Joined
·
104 Posts
Discussion Starter #15
Timing is stock is a 93 cobra everything is originalwad running fine before he started doing everything all he hid was ad a fp regulator and pump injectors and the turbo
 

·
Registered
Joined
·
3,647 Posts
When you ordered the chip did you tell him for a 93 Cobra? That setup will use a different chip.
 

·
Registered
Joined
·
444 Posts
Timing is stock is a 93 cobra everything is originalwad running fine before he started doing everything all he hid was ad a fp regulator and pump injectors and the turbo
are u using a 93 cobra computer they r set up for 24#injectors and same as the stock mass air may be the cause of all your problems and unless u have somethen to retard the timing it wont be runing for to long under boost
 

·
Registered
Joined
·
448 Posts
my question is how did he get fuel coming from the compressor side of the turbo? did i read that right?
 

·
Registered
Joined
·
448 Posts
i did post # 9 op. how is it even possible to get fuel on the compressor side with an injected car? if it's running that rich you may have an injector stuck open, it's not very common but it does happen. and your plugs would be BLACK and shiny not white. If they're that white you are prolly super lean especially if it's all ashy which could mean you have a fpr NOT pinching off the return line which would cause a lean condition. and what's the timing set at. should be at around 10* base, but i'm not sure what kind of advance is dialed into a 93 cobra ecu probably more than what an A9L box has but i have no idea. there's a few things to check really need more info on the setup to give you a better answer.
 

·
Registered
Joined
·
1,378 Posts
what kind of injectors did you put in? when i installed brand new injectors one of them ws bad! it was stuck open all the time. would empty the fuel rail. in seconds. fuel would puddle in the crossover tube.
 
1 - 20 of 35 Posts
Top