Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
297 Posts
Discussion Starter #1
i have mine on 18 base which is about 34 total right now but plan on going alittle lower ! the tips of my plugs look alittle burnt and i'm running the stock autolite plugs 764 something like that......
 

·
Registered
Joined
·
705 Posts
I picked up 2 tenths with my old gt40p combo by knocking the timing down to 14* and swapping to a autolite 103 plug. The heads were milled a good bit so compression might have been a little high. Maybe close to 10:1. I really found this out by accident, I was running nitrous with the setup like that and found the car ran better on all motor that way too.
 

·
Registered
Joined
·
297 Posts
Discussion Starter #3
I picked up 2 tenths with my old gt40p combo by knocking the timing down to 14* and swapping to a autolite 103 plug. The heads were milled a good bit so compression might have been a little high. Maybe close to 10:1. I really found this out by accident, I was running nitrous with the setup like that and found the car ran better on all motor that way too.
yeah my car runs good but it just doesn't feel right ! like there is more there somewhere........i turned my fuel back up to 39 from 35 and help a whole lot much peppier but still lacks topend ? its funny you should mention the spark plugs because mine look alittle funny like there to hot so i thought about going a step colder !
 

·
Registered
Joined
·
132 Posts
Try this, take the timing spout out, put timing at 34-36 degrees locked out. LEAVE SPOUT OUT...Try running like that and see if it likes it. We have always ran it that way with timing locked out. Also if it does like that, then try to run with 40-45lbs of fuel pressure. Keep going up with pressure until ur ET drops off.
 

·
Registered
Joined
·
297 Posts
Discussion Starter #6
Try this, take the timing spout out, put timing at 34-36 degrees locked out. LEAVE SPOUT OUT...Try running like that and see if it likes it. We have always ran it that way with timing locked out. Also if it does like that, then try to run with 40-45lbs of fuel pressure. Keep going up with pressure until ur ET drops off.
Hey John,

well i turned my timing up to 36 and locked it out, well it revs better but it started surging and i checked a plug after idleing and they were turning black ! so i don't know if turning my fuel psi up to 39 done it or the locking the timing out ? i drove my car earlier with the timing on 18 base and 39 psi fuel and it didn't surge ! also made a run last night in 3rd pulled over and checked a plug and they looked normal so i don't know whats making them turn black al of a sudden ! i think my o2's are flaken out because the car runs better with them unplugged it seems like....... but i have to lean the idle out a bit with my safc to keep it from surging !
 
1 - 6 of 6 Posts
Top