Ford Mustang Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Hi guys I was wondering what everybody thought about this kit I know a few years back the feedback wasnt that great but I heard the company is on the up and up and has really improved in recent years what do you guys think?
 

·
Super Moderator
Joined
·
27,657 Posts
Best bet is the search function.
 

·
Registered
Joined
·
513 Posts
Hi guys I was wondering what everybody thought about this kit I know a few years back the feedback wasnt that great but I heard the company is on the up and up and has really improved in recent years what do you guys think?
I just installed the hot side on mine today. It went pretty well. I will be doing the cold side tomorrow.
 

·
Registered
Joined
·
7,019 Posts
yeah a good question for the "turbo tech" section... IIRC, the fox stuff had decent fitment but the later stuff was hit or miss. quality, your gonna get what you pay for, chinese parts but a good price and good power... if longevity is a concern, get a better quality kit.
 

·
Registered
Joined
·
513 Posts
PHP:
Hi guys I was wondering what everybody thought about this kit I know a few years back the feedback wasnt that great but I heard the company is on the up and up and has really improved in recent years what do you guys think?
Just finished the cold side install. It went together very easy. Not one firmest problem. Headers are nice and straight. The only issues I had were as follows:

Missing one drain bolt
Missing one turbo boly and lock nut

I just went to Ace Hardware and picked those up for $2.29.
 

·
Registered
Joined
·
53 Posts
I'm installing mine right now in my 95,just finished the hot side,had to loosen up my sway bar so I could get the driver side header in and the clamp on,the header bolts or headers have some issues,jade to grind down the collars on the header bolts to get them in,done deal now,I was missing 2 clamps for the exhaust,y pipe and cut out,Greg is sending me two clamps,just got the vacuum line for the gate hooked up,had to get a couple extra brass pieces FLT the oil feed and sending unit so all in all wasn't to bad but not without issues,we will see how the cold side goes tomorrow and Tuesday being I have some other things to do.
 

·
Registered
Joined
·
167 Posts
So is the quality of the kit better than previous years? Or about the same?It always seems iffy with on3 lol
 

·
Registered
Joined
·
513 Posts
I will be starting and driving mine for the first time tomorrow. Everything fit fine. No major modifications required so far.
 

·
Registered
Joined
·
737 Posts
I have on3 hot side and have had no issues with it.
 

·
Registered
Joined
·
513 Posts
Burning Rubber12, any updates?
Ended up having to buy a megasquirt. It was way too rich down low. Would barely run. I leaned it way out and it ran good enough to drive around the block. But got way lean past 3000 rpm. Should be installing megasquirt shortly. Have exhaust leaks on the hot side. Passenger side v band leaking and where two hot pipes meet leaking. Other than that no problems with the kit.
 

·
Registered
Joined
·
994 Posts
No issues with any of my kit, including leaks. Been on the car for about 4 years now. But, before I even bolted it on, I had all the surfaces machined flat. :wink2:
 

·
Registered
Joined
·
1,187 Posts
The only issues I have ever ran into with their kits is cracking. This is due to excessive pressure and wear. I run their kits pretty hard so its not uncommon. The only cracking I have ever found was pass header where the cross flange exit meets the pass header. The "V" weld around where the T4 flange is. I have had 1 of the 02 bungs crack as well and the wastegate flange that is welded to the cross. Again, this was all easy fixes really just had to grind it down go over it with a welder. As for turbos, I had a few leak on me but I put a set of good seals and 360 thrust bearings in from a rebuild kit voila.. like it was new no smoke. Lastly I had a couple of the crossover flex tubes fall apart inside on me. Again I run these hard and I do put some miles on them. I just cut it out with the ball and socket hook up and fab a new forced induction style flex tube in its place. Done...
 

·
Registered
Joined
·
341 Posts
My v-band leaked where the driver side header met the crossover but that was because I just didn't tighten it down enough.

I guess I have a flawless kit.
 

·
Registered
Joined
·
513 Posts
My v-band leaked where the driver side header met the crossover but that was because I just didn't tighten it down enough.

I guess I have a flawless kit.
I am still thinking that my van don passenger side may not be tight or need to be repositioned.
 

·
Registered
Joined
·
110 Posts
Have one on my 351w carb setup with only minor fit issues.. (Discharge pipe from fender to carb wasn't long enough..). 3"pipe cut to fit fixed that...

Other than that no issues...

My buddies 04 with on3 fit like a glove also (minus) carb pipe length as well...
(I assume on3 thinks the carb/EFI are the same length but are not..)

Other than that... They fit and work well...

My 358carb set-up tossed out 700ish with no problems... @15lbs...

His 302 (4.6) with all the bells and whistles I'd say from the "feeling", has around 650-700... But it does come on a bit later then my 358...

He does run 93, I however run E85
 

·
Registered
Joined
·
53 Posts
Have my on3 kit all installed and it went good after I thought things thru like leaving everything as lose as possible,when all said and done the biggest issue was the driver side header,the bolts didn't line up on a few,they were like 3mm off so I just drilled them out and then no issue,bolted right on,the biggest thing is leave everything as lose as possible and the kit should go on without issue and remember there is some cutting and grinding and drilling involved,it's not a plug and play but close.
Now if I can get my BE to talk to the QH I'll be happy.:grin2:
 
1 - 19 of 19 Posts
Top