Ford Mustang Forums banner

1 - 20 of 49 Posts

·
Registered
Joined
·
839 Posts
Discussion Starter #1 (Edited)
So 2002 mustang gt just installed an on3 rear facing turbo kit with the on3 70mm turbo and on acceleration at about 2800-3800 it sounds like a bad rattle. When I decelerate in gear at the same RPM is sounds just like a big rig Jake Brake. Anyone else have this issue?

I have thought about putting an exhaust clamp on the downpipe from the turbo and Turin it to the engine to stop the pipe from vibrating.
 

·
Registered
Joined
·
839 Posts
Discussion Starter #3
sounds like you may have a bad exhaust leak. check your hot side flanges and clamps
No leaks had a buddy plug the exhaust tailpipes so i could listen to all the fittings no leaks at all
 

·
Registered
Joined
·
839 Posts
Discussion Starter #5
just noticed you are in nashville. i could take a look at it. just sounds like something is loose but hard to say
Where you located?

I just went thru this mornign and used enough Ultra Copepr to sink the titanic. Lets see if it helps
 

·
Registered
Joined
·
839 Posts
Discussion Starter #11
Man I put enough Untra copper on that thing to mold an entire engine and it still is there. Now please forgive me I am new to the turbo world, and I must say other than this sound, I love it....

What Flashing are you talking about?
 

·
Registered
Joined
·
2,937 Posts
no worries, I meant flashing as in loose cast aluminum thats been known to be in some of these on3 turbos. Can you check to see that the wheel spins freely?
 

·
Registered
Joined
·
839 Posts
Discussion Starter #13
I can spin the turbo by hand no issues and it spins at idle
 

·
Registered
Joined
·
932 Posts
Are you hearing the bov going off ? Turbo flutter caused by back pressure can make that sound.
 

·
Registered
Joined
·
1,977 Posts
Mine does it sometimes...i think its the blow off...just like mentioned above..it does it if im like half throttle and letting off while its still between building boost hard to explain...but if im going hard i never it hear it...
 

·
Registered
Joined
·
839 Posts
Discussion Starter #16
The blow off valve is wrking fine. I hear i blow off just like it should. This is on excel or decel at about 2800-3800. It does it every time even when I am not boosting.
 

·
Registered
Joined
·
1,977 Posts
My blow off works fine too..you hear it over a block away..LOL...but mine makes that noise too...ive heard it too..I just except it to be the nature of the beast...it builds boost fine runs great been that way for a 1yr now...
 

·
Registered
Joined
·
839 Posts
Discussion Starter #18
I will try to get a video today that shld help everyone that's been good enough to help me diagnose this.

Thank you
 

·
Registered
Joined
·
2,937 Posts
my93, is it something new, i dont remember hearing it in the videos you put up a while ago
 

·
Registered
Joined
·
1,977 Posts
my93, is it something new, i dont remember hearing it in the videos you put up a while ago
Mine does it more when your above 4000 rpm...it sounds like back pressure hitting the pipes if that makes sense hard to explain but it has done it since the day i picked the car up from the shop...Your going to laugh but i kinda like the sound...lol...But like in my video that car is basically quiet...just hear the blow off..well you heard the video..lol..the turbo doesnt whistle that much either on the highway when you spool it up you hear the whistle tho..Its hard to build boost on the streets..lol...because your flying when it does....;)
 
1 - 20 of 49 Posts
Top