Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Guys I really need some help here. Trying to get my build done and the problems keep comin. It's a freshly rebuilt motor with trickflow heads, all new top end and the on3 kit with the cheaper turbo. I got the initial timing dialed in at about 13 degrees and the fuel pressure at 38. 42lb injectors with a calibrated maf. after Running the motor a few times a lot of smoke would be coming out. after running long enough I found oil pouring out the exhaust. its a brand new turbo and its leaking oil out into the exhaust turbine. I tore apart the turbo cuz I really can't afford a nicer one at the moment. I know people have had these problems is there any way of fixing it myself I can post up pics of the inside but does anyone know where it is most likely leaking from. If I get this leak fixed it should be good after a tune. Basically almost got the motor running but it just will not idle on its own. Please any help would be appreciated. I got a month to get this car driveable
 

·
Registered
Joined
·
646 Posts
well, It may not be the turbo itself, It could be too large of feed line and needs reducer, or could be drain on turbo not draining because of size or angle of line
 

·
Registered
Joined
·
156 Posts
Check and recheck the drain line, try it at different angles and routing.
Mine smoked bad at first start up bc i had the drain routed where it was backing up.
get it at the straightest angle possible, shorten it if you can.
 
1 - 3 of 3 Posts
Top