Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
393 Posts
Discussion Starter #1
Hello, just puttin some miles on my car fresh from the dyno and noticed after a decent pull when I come to a stop a cloud of oil smoke follows me. I also found a little oil in my downpipe too. Has anyone had to run a restrictor on the on3 T70? I think think think my built motor has a high flow oil pump and I might be choking this chinese turbo.
 

·
Registered
Joined
·
1,977 Posts
I have a stupid question how would you know if you really needed one?...Also how would you know if not enough oil wasnt getting to it?
 

·
Registered
Joined
·
1,195 Posts
I ran into same issue. Turbo can't withstand much more then 75psi oil pressure. Mine sees much more then that at wot. Grab a restritor. It should fix ur issue. I got a .068 restrictor and drilled it out to a .080.


Sent from my iPhone using AG Free
 

·
Registered
Joined
·
753 Posts
I have a stupid question how would you know if you really needed one?...Also how would you know if not enough oil wasnt getting to it?
Imho anything over 60 psi I would run one. Most guys run one when they are leaking oil pass the seals and smoking alot. I have been running a .065 restrictor with a journal bearing turbo for 2 years no issues. I see 90 psi on cold starts and 70-80psi under wot. I guess you would know its not enough if you hade seal failure from heat issues then again seals are already leaking due to too much pressure...
 
1 - 6 of 6 Posts
Top