Ford Mustang Forums banner

1 - 20 of 58 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
Here are my on3 numbers with really bad exhaust leak 430/426 on 12lbs of boost I have a chart and would like to get it up here bit don't know how to post pics on here
 

·
Registered
Joined
·
2,531 Posts
where is your exhaust leak?

I have one as well and it's on the hot side where the flanges connect to the flex pipe
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
Mine are at the v bands where the headers connect to the merge pipes and where the passenger side pipe connects to the merge pipe by the flex coupler so all three of my v bands are leaking basically
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5 (Edited)
Stock motor 2003 GT centennial edition coupe 3.73 gears on3 forward facing kit with ceramic ball bearing 67mm turbo AEM tru boost controller and wideband and I also still have my steeda underdrive pullies still on
 

·
Registered
Joined
·
96 Posts
Discussion Starter #8
St. Paul area. Im hoping to get my exhaust welded or fixed I think that fitment is just a little bit tough so its twisting and bending my hot side not allowing my vbands to work correctly or my v bands are just crap but people tell me that you shouldnt have to copper rtv v bands which I guess I didnt know I just did anyways and it blew all the rtv out I also made 365/383 on 8lbs the week before but went back because my tru boost wasnt working right so i fixed it and got the boost to go up to 12lbs
 

·
Registered
Joined
·
579 Posts
Hey contact jaidedeye he had no problems with his so you probally installed it wrong.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #10
yea im thinking it needs to be fitted a little better is all because theres a tension or stress thats causing the ends to not mate together quite perfectly in that case the vband will not seal properly
 

·
Registered
Joined
·
2,012 Posts
Ryan's dyno , posting pictures for him


 

·
Registered
Joined
·
2,531 Posts
Mine are at the v bands where the headers connect to the merge pipes and where the passenger side pipe connects to the merge pipe by the flex coupler so all three of my v bands are leaking basically

ok..so basically we have the same leaks..

I'm taking mine to exhaust shop and having them cut and weld on 3-bolt flanges so i don't have to deal with those clamps anymore...and I'm 100% sure will fix those leaks..

We're basically losing 1to1.5 pounds of boost from there
 

·
Registered
Joined
·
96 Posts
Discussion Starter #13
Have you tried repositioning them and tightening the v bands back down? I was going to cut the merge pipe behind the flange then mate the flanges together with the v bands
And re weld it from there and then the v bands should seal properly
 

·
Banned
Joined
·
1,137 Posts
Hey contact jaidedeye he had no problems with his so you probally installed it wrong.
there are known leaking issues with the mod motor kits due to the way the pipes are routed.....

bring your junk up the NC....you wanna be a smart ass...more than happy let you do it in person and get you get your birthday taken away by my On3 kit..............

BTW.....lets see pictures of your car..........you are so name brand loyal the thing better be mint.....
 

·
Banned
Joined
·
1,137 Posts
^^^ Known problems ? No kidding. This is the new and improved kit they are talking about you know.


i have the 5.0 kit...not sure why the other clown keeps generalizing...i guess since B&G sells Chinese kits he has to run his mouth about something else..

he needs to go back to turboforums. he is just as much a jackass over there
 

·
Registered
Joined
·
549 Posts
i have the 5.0 kit...not sure why the other clown keeps generalizing...i guess since B&G sells Chinese kits he has to run his mouth about something else..

he needs to go back to turboforums. he is just as much a jackass over there
oh so your saying only half their kits are crap lol totally playing man i couldnt pass that one up. whats the rest of your ON3 combo?
 

·
Registered
Joined
·
2,531 Posts
Have you tried repositioning them and tightening the v bands back down? I was going to cut the merge pipe behind the flange then mate the flanges together with the v bands
And re weld it from there and then the v bands should seal properly
yeah..I've tried everything..

I'm going to cut and have 3 bolt flanges welded in...
 
1 - 20 of 58 Posts
Top