Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
393 Posts
Discussion Starter #1 (Edited)
I'm in the middle of installing my ON3 kit, it's the original version. I bought it brand new last year but just getting to it right now. Car is 2004 GT

Basically, the V band joint in the passenger fenderwell, ( pipe comming from driver's manifold and the merge pipe) are pretty far off, like 1/4" or more.

The pipes are all loose and I tried twisting and adjusting, ain't no way it' gonna fit. Second problem is, the angle of the two v band flanges are off by about .125 so even if I managed to force them together it won't fully seal.

Has anyone ran into this? How have you dealt witht this issue?

I was thining about putting a V band flanged flex joint there?

I messaged ON3 last week about emailing me their instructions and got no response and my calls went unreturned, so those responses saying to let them deal with it are useless.


Thanks
 

·
Registered
Joined
·
1,361 Posts
I have the 2nd gen FF kit but this applies to all kits.

Did you leave all the v band connections loose and then tighten them each a little at a time?

If you dont, they probably will be all out of wack.
 

·
Registered
Joined
·
393 Posts
Discussion Starter #4 (Edited)
all the clamps are loose, but this joint is very out of whack. I deimpled the pipe a little so it could swing up a little more and it helped but it's still .100 -.125 off at the top of flanges


Now here is my actual joint,


I have gotten it close now, to where the bottom of the flanges touch but the top is still off .100 and they are slightly out of line, by about .100 also

I'm unsure if the problem is the merge pipe, or the smaller U shapped pipe that goes directly to the driver's manifold. I do think at this point the turbo inlet flange is pointing at an odd angle so perhaps the merge pipe is ####ed.
 

·
Registered
Joined
·
393 Posts
Discussion Starter #5
Update

After messing with this for a few more days it's become very clear the pipe from driver's manifold to the merge is fab'd wrong and is not going to fit, at all. So the car and rest of the kit is getting trailered to PSI where Frank can fix this ####.

I am suprised I ran into this, the other kits I helped install for a foxbody and a 2v fit great. Mine must have been fab'd on a Friday.
 
1 - 5 of 5 Posts
Top