Ford Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #1
Can I run a NITTO Extreme Performance NT555 275/40-17 on the front with my 1st gen kit? I have 245 45 17 on now with 1/4 spacer and they rub a little . I just don't know how much more they will rub with the bigger tire . Is anyone running a 275/40/17 if so how is it working for you?
 

·
Registered
Joined
·
2,012 Posts
When I had gen 1st kit and 275/35/18 it rub , stay smaller tire.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #3
I just knew you (2002mustanggt) were going to say that . Heck you have answered all my questions . I don't like skinny tires :(
 

·
Registered
Joined
·
2,012 Posts
I just knew you (2002mustanggt) were going to say that . Heck you have answered all my questions . I don't like skinny tires :(
;) always ready to help. I'm the same is why I had 275 up front and 295 out back but pipe will burn tires . Just try not to do full clock turns.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #6
Tks Bwaite I am going to go w/the bigger tires . after taking a closer look I think the rub is more from the 9in rim than the size of the tire. I know I will have more rub but I don't think its going to be much .
 

·
Registered
Joined
·
932 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #8
Just got back from picking up the new tires . (took rims off car) and the 275/40/17 up front is wide . Just took it for a ride and they don't rub that bad with a spacer in there. Just a little more rub than I had with the 245/45/17 . I might hammer on the passenger side pipe to get some more clearance but its fine for now ..
 

·
Registered
Joined
·
932 Posts
Just got back from picking up the new tires . (took rims off car) and the 275/40/17 up front is wide . Just took it for a ride and they don't rub that bad with a spacer in there. Just a little more rub than I had with the 245/45/17 . I might hammer on the passenger side pipe to get some more clearance but its fine for now ..
I don't know if they made changes on the kit but there is no way 275 up front would ever rub on passengers side on mine. The drivers side know that's a different story.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #10
I made a hanger and lifted the passenger side piping when I installed the kit . I think that is what is causing the passenger side to rub . I did remove the shims last night .They brought the wheels out too much .I heated the piping and persuaded them in some with a steel tube and 5lb sledge Now I have less rub than I did with the shims . :) Couple more whacks and I bet it wont rub at all .
 
1 - 11 of 11 Posts
Top