Ford Mustang Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
1,361 Posts
Discussion Starter #1
Am I the only one that has had issues with the oil lines popping off with this setup?

Its the on3 oil filter relocation kit on a 4.6 2v and ive had both lines pop off on me now.

Its a simple hose and barb connection with a clamp....I did upgrade to larger clamps after they came off but im just wondering if anyone else has had issues with these things flying off?

The damn thing nearly burned my car to the ground the other day....luckily I had an extinguisher.
 

·
Registered
Joined
·
383 Posts
Ditch the crappy push on hoses and get some AN braided hose with AN fittings.
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #3
I would if it was accessible. I don't even think I can get those stupid ass fittings off with it installed and on the car.

Sent from my DROID RAZR using Tapatalk 2
 

·
Registered
Joined
·
753 Posts
Happened once, tighten down the clamps and been good for 2 years, I ahve a relocation kit from summit. That being said I have seen guys have it come loose and dump oil everywhere, so istn worth risking the motor either and I will be upgrading to ss lines and an fittings for mine here shortly.
 

·
Registered
Joined
·
2,287 Posts
Man you just dont have any luck do you LOL. I tightend mine down good the first time and havent had a problem yet. I work at a tractor dealer and we build hydraulic hoses. I am thinking about taking them off and builing 2 hoses with swivel ends so I can install them easier. If I get around to it anytime soon Ill let you know how they work out. I know they will be just as good if not better than the an lines because the hydraulic lines are made for extremely high pressure and temps. and the ends are crimped on in a press. where do you have your filter mounted?
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #6
Interesting, well im not really worried about losing the motor because its obvious when it happens....like 100 foot trail of white smoke. lol

Just not very fun when it happens and obviously want to prevent it from happening.

Ruffled, no man, I swear if anything can go wrong, it will when it comes to this car.

Im surprised the piping hasnt cracked in half yet lol

I will say its probably somewhat my fault for using the wrong clamps...I used these smaller, thinner ones. Seems like the thicker ones work a lot better.

I was just curious if other people had issues or not.

Anyways, ive got my filter mounted on the backside of my bumper support.

I would switch to AN lines if I could get to it.

With the way the stupid ass fittings screw into the adapter piece you cant even get a wrench on it.
 

·
Registered
Joined
·
549 Posts
I switched to that plate that moroso makes and got rid of the regular adapter and that thread on cap the only thing is you have to switch up your lower radiator hose set-up to a -16 an style but it was the best thing I ever done works great.
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #8
Yea, damn that would have been a good idea, it just sucks cause that adapter plate is literally impossible to remove with the motor in the car.

Wish I would have done it before hand.
 

·
Registered
Joined
·
257 Posts
Yea, damn that would have been a good idea, it just sucks cause that adapter plate is literally impossible to remove with the motor in the car.

Wish I would have done it before hand.
You have to be very patient. Mine was leaking when i installed it the first time, so i actually pulled it and re installed it with it on the car. I have a 03 mach 1, dunno if yours is much different? Either way, took me like 2 hours. Im a very patient person lol, either way faster then pulling your header or any of that non-sense....

As for the hose, yes mine just blew off last week. It blew off at WOT too, luckily i have a oil pressure gauge and the pipe is right below it so the second i saw smoke i let out of it. I went and bought all new clamps and everything seems to be fine.
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #11
You can pull the drivers header off and pull it off

Sent from my DROID BIONIC using Tapatalk 2
Lol, you say that like its easy to get too.

I really dont know how people get to these bolts. I had a tough time getting to some of those bolts with the motor out of the car with the way the header was designed.

Im not sure I could even get to all the bolts.
 

·
Registered
Joined
·
2,287 Posts
I installed mine in the car. But I didn't have a k-member in at the time. Now that everyone has had problems it looks like ill be changing mine out even sooner.

Sent from my DROID BIONIC using Tapatalk 2
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #13
I installed mine in the car. But I didn't have a k-member in at the time. Now that everyone has had problems it looks like ill be changing mine out even sooner.

Sent from my DROID BIONIC using Tapatalk 2
Lol, it seems like people are fine when they use nice clamps and crank em down.

Definitely not a good idea to leave them loose at all.
 

·
Registered
Joined
·
383 Posts
So on the 2v FF kit you can install the headers with the motor out and drop in the motor with the headers on the motor?
 

·
Registered
Joined
·
277 Posts
i just had a line blow off today...what a mess. i have my filter on the passenger firewall and oil covered the motor and fenders. it also got me and my friend. i just ordered -an fittings and hose ($175)tonight. i guess i was lucky it happened in the driveway.
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #17 (Edited)
i just had a line blow off today...what a mess. i have my filter on the passenger firewall and oil covered the motor and fenders. it also got me and my friend. i just ordered -an fittings and hose ($175)tonight. i guess i was lucky it happened in the driveway.
Yours blew off the connection by the filter?

Mine blew off the connection right off the motorm
 

·
Registered
Joined
·
383 Posts
i just had a line blow off today...what a mess. i have my filter on the passenger firewall and oil covered the motor and fenders. it also got me and my friend. i just ordered -an fittings and hose ($175)tonight. i guess i was lucky it happened in the driveway.
Dang, $175 on fittings and lines? I spent that much or less on my entire return style fuel system.




Is there a lot of fittings for the relocation or hard to find/expensive fittings? Seems like it would be 6-10 fittings and about $30-$40 in hose.
 

·
Registered
Joined
·
1,361 Posts
Discussion Starter #19
You spent 175 on a return style fuel system?

jeez, mine was 1300~, I need to shop where you shop!!!

####, my regulator was 175.

I dk what he bought but I know random fittings can be crazy expensive, I think I spend 200 dollars on random fittings and lines to get my eddy victor manifold to work with the stock fuel system lines.
 

·
Registered
Joined
·
383 Posts
You spent 175 on a return style fuel system?

jeez, mine was 1300~, I need to shop where you shop!!!

####, my regulator was 175.

I dk what he bought but I know random fittings can be crazy expensive, I think I spend 200 dollars on random fittings and lines to get my eddy victor manifold to work with the stock fuel system lines.
No just fittings and lines i ment, my setup was $1,300 pieced together myself.
 
1 - 20 of 29 Posts
Top