Ford Mustang Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
789 Posts
Discussion Starter #1
Finished install on my on3 kit for the 02 stang. Running a victor jr lower intake and accufab upper intake. Obviously the vaccum lines are now not the same as a stock setup.. The turbo is spinning but no boost is shown on the gauge. It has vaccum..but no boost. Plus the wastegate/BOV are not functioning properly. HERE IS HOW I HAVE THE LINES EOUTED: the one port on the back of the upper plenum has a big line hooked on it. Off of that there are two smaller hookups. One of those has a vaccum line that goes straight to the waxtegate..the other one has a T-fitfing..which has one line to the BOV and anothed to the boost gauge. So all my vaccum lines are connected to that ons podt in the back.. Is that right?????? The one port on the front is not being used. Running the check valve where it was but the ond beside it is now vacant. Does that vacant one just need plugged? Help pls..this is all new to me!
 

·
Registered
Joined
·
711 Posts
SOunds like your BOV is not getting vacuum; I would check the hose going to it and make sure you can feel vacuum while the engine is running, sice vacuum is what keeps the BOV closed.

Second I would use a boost/vacuum source as close to the turbo as possible for the watsegate; this mainatains an accurate reference.
 

·
Registered
Joined
·
789 Posts
Discussion Starter #4
BOV is functioning ok. at idle its open..hit tge gas it closes shut. the turbo is spooling..i can.see it turning when I take the filter off. I checked the wastegate when the car was at idle..and with higher rpms. in neither circumstance sas therd exhaust coming out of if. There is a vaccum line running to the wastegate..but if sees no vaccum?? Seems like the wastegate just isnt functioning properly. So if the turbo is spinning doesnt that mean that bkost is being made? How would I tap it directly to the turbo housing? And what purpose would that serve
 

·
Registered
Joined
·
789 Posts
Discussion Starter #5
BTW.. When I rev the engine up and let off of it there is no psshhh. Two things. One: no boost is being made.. Two: boost is there but not being released thru the wastegate. Maybe the wastegate is stuck!
 

·
Registered
Joined
·
3,716 Posts
Might want to find someone local who has experience and can help you out. Just because the turbo is spinning doesn't mean your making boost
 

·
Registered
Joined
·
865 Posts
have you tried driving it at all to see if it makes any boost? usually if you rev in neutral you have to spin it pretty good to get any boost and its not much
 

·
Premium Member
Joined
·
1,535 Posts
You will not see boost unless you drive it. There needs to be a descent load for it to build boost. I went through same thing. Even on jack stands nothing. Hit the street wamm, sideways she went making 6-8 psi on smallest spring. :)

Sent from my PI86100 using Board Express
 

·
Registered
Joined
·
753 Posts
Bov should be shut at idle or you need a stronger spring/shim.

Like mentioned you wont see any boost revving at idle.

If you have an open port on a avc block then you need to plug it or you have a huge vac/boost leak.

You don't seem to understand exactly how the system wastegate functions so I would
do some research on the matter. If the wastegate was stuck shut you would make lots of boost lol.

Bov and gauge to a manifold vac/pressure source.

Wastgate top port open and side port to a pressure only source. ie turbo housing or piping just
downstream of the turbo.
 

·
Registered
Joined
·
789 Posts
Discussion Starter #10
Yeah I thought bout the fact that boost wouldnt register without a load on the engine. And yes..this is my first turbo install so pardon my rookie questions! let me get this straight.. The BOV should be closed at idle and open at throttle? Cuz right now its the opposite.. And I should run my line from the side port of the wastegate to tne pipe that attaches to the rurbo..and NOT to the upper intake port??
 

·
Registered
Joined
·
448 Posts
The blow off valve will be OPEN at IDLE and CLOSED while in BOOST. Think of the BOV as a vacuum actuator it sucks open and blows shut.

The wastegate has a spring inside it that keeps is shut at all time with pressure. Once the system begins to build boost at some point the turbo will create more boost or pressure than the spring does. At this point, the pressure from the turbo is greater than the pressure from the spring thereby opening the valve at the wastegate. When this happens, the exhaust gases used to spin the turbo and create boost are re-routed so as to not continue spinning the turbo faster but keeping it at a constant speed. The wastegate will remain shut until the desired level of boost is achieved then it opens. You WILL NOTICE THIS.

Please keep in mind that you have to put a load on the turbo to make it spool. It will not make any boost without driving the car. You might notice a whoosh of air from the bov if you rev it up high enough but, where's the fun in that? Drive the car but for the love of god be careful it will be a lot faster now.
 

·
Registered
Joined
·
456 Posts
post some pics my friend
 

·
Registered
Joined
·
1,378 Posts
The blow off valve will be OPEN at IDLE and CLOSED while in BOOST. Think of the BOV as a vacuum actuator it sucks open and blows shut.
WRONG THAT IS A DIVERTER VALVE FOR S/C CARS AND THEY NORMALY SEND THAT AIR BACK IN FRONT OF THE MAF!!! YOU DONT HEAR TURBO CARS RUNNING AROUND WITH OPEN BOV

BOV only open when a rapid change happens in the vacum! this is why they stay shut all the time then when going from boost to vacum they open

and call ON3 THEY WILL VERIFY THIS ^^
 

·
Registered
Joined
·
247 Posts
hmmm,
mine stays open at idle and closes under boost also.






WRONG THAT IS A DIVERTER VALVE FOR S/C CARS AND THEY NORMALY SEND THAT AIR BACK IN FRONT OF THE MAF!!! YOU DONT HEAR TURBO CARS RUNNING AROUND WITH OPEN BOV

BOV only open when a rapid change happens in the vacum! this is why they stay shut all the time then when going from boost to vacum they open

and call ON3 THEY WILL VERIFY THIS ^^
 

·
Registered
Joined
·
2,287 Posts
If you have all the couplings tight and have no leaks then either your waste gate or blow off valve is open. Verify the vacuum source and make sure they are connected in the correct place on the wg. I have one vac line from the manifold going to a t and then out to the bov and wg.

Sent from my DROID BIONIC using Tapatalk 2
 

·
Registered
Joined
·
994 Posts
hmmm,
mine stays open at idle and closes under boost also.
Mine too. Slightly open at idle. Closes as soon as the RPM climbs above idle, and then opens again when you let off the throttle.
 

·
Registered
Joined
·
865 Posts
Mine too. Slightly open at idle. Closes as soon as the RPM climbs above idle, and then opens again when you let off the throttle.
same as mine
 

·
Registered
Joined
·
48 Posts
I don't have a turbo yet, (soon I hope!!!) but from reading about it... vacuum is what causes the BOV to open. When the car is on idle, the throttle body blade is closed and the running engine pulling against the closed TB creates vacuum. The BOV should be open, even if partially. Raise RPM, TB opens, vacuum drops off, BOV closes. Lift off throttle, TB closes, engine creates vacuum again and BOV opens to blow off pressure in order to keep from damaging turbo... Somebody speak up if this is incorrect, please.
 
1 - 20 of 34 Posts
Top