Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,363 Posts
Discussion Starter #1
1.536 60ft
4.515 330ft
[email protected] 660ft
9.156 1000ft
[email protected]

3 step was broke so I had to leave against the convertor on the transbrake. I am also having traction issues. I have videos of the car launching from behind and the car leaves like its on a rail it just goes. I lifts the nose but I have the adjusters all the way down to get the ride height I want with 150# springs so I will try 130's and see if that will make a difference. Will also be looking for a 2 step if anyone has one

Rex
 

·
Registered
Joined
·
1,239 Posts
Got a 10, way to go :) You saying you have the front end sitting low? I'm about to put a tubular front end and coil overs on mine and I was told that the ride height may have to be a lil high with my 150's to get the best traction. Would a 130 let it sit lower and still hook good? I don't know squat about suspension :idunno:
 

·
Registered
Joined
·
1,363 Posts
Discussion Starter #3
yeah the spring has no tension when the front end is fully extened so it doesnt keep the shocks from going back down.

Rex
 

·
Registered
Joined
·
4,225 Posts
Congrats on the 10 rex! That's great and will only keep getting better.

Swapping out my front 175's to a pair of 130's really woke up the launch even with the heavy ass windsor up front. With the 14" spring I have a pretty decent compression on them at rest and it really throws the front up when it leaves. I've even toyed with a lighter spring yet but it's working well so it's kinda fell off the priority list.
 

·
Registered
Joined
·
1,363 Posts
Discussion Starter #5
I am gonna head to strange tommorrow and pick up a set of shocks and springs tommorrow and put em in this week. I got a few maintenence items I need to take care of too. So time to go back up on jack stands :)
 

·
Registered
Joined
·
1,363 Posts
Discussion Starter #6
Well got the new shocks install and while I had the tires off notice one had been cut so they are gone and now a new set of MT 28x10.5's are on there :) May tackle the springs tommorrow if my bumpsteer kit shows back up from steeda.

Rex
 

·
Registered
Joined
·
1,363 Posts
Discussion Starter #7
Well a quick update. Just watched the video of the passes. Alot of things came out...........

#1 Weight Transfer isnt as big of a problem as I thought it was..... Paused the video and took a pic.

#2 Car was spinning bad out of the hole.....Attribute that to not have a limiter and having to leave at 6k and hoosiers dont seem to hook as well at M/T's. Will pick up and install a new two step Saturday.

#3 Tires were unloading a little ways out.....Replaced 50/50 shochs with adjustable stranges should prevent this.

So hopefully with the new two step, new tires, and new shocks car should 60ft in the 1.4's.

Rex

Paused the video and shot this pic. This was in the non VHT'd lane.

 
1 - 9 of 9 Posts
Top