Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter #1
Hey guys...here's the symptoms.

Driving around, I noticed that my speedometer quick working. The needle just dropped as if the car is shut off. It will work periodically. Then tonight I am on the highway just driving for the fun of it, and I am in the median crossover turning to the other side of the highway, and the car dies. It was idling when this happened. Turn it back on, and my "service engine soon" light is on, my Traction control won't toggle on/off, and my speedometer digital display read "- - - - - - -" instead of like "24059" miles.

I have no clue what it is, I just bought this car and am not really familiar with them yet. ANY ideas?

By the way, the car DOES have a gear, and one of those chips or whatever they are that corrects the speedometer. Could this have anything to do with it?

thanks a LOT guys
 

·
Registered
Joined
·
369 Posts
You need to determine if the car has an ABBOT (converter box wired into the speed sensing system) or whether the speedometer was corrected for the gears using a chip inserted into the EEC (Electronic Engine Controller). The Abbot is a small rectangular box (about cigarette box size if I recall correctly) that would probably be somewhere behind your passenger side rug or kick panel. If you have one of these, it may just be a loose wire causing your problems.
 

·
Registered
Joined
·
199 Posts
hey man i had the same problem. I have a dallas speedcal in my car adn that was teh culprit. it wasn't that the unit was bad...it was that the power to the unit got disconnected and all I had to do was reconnect it and everything was fine.

the second time it happened to me it wasn't the speedcal that was the problem. I was cleaning my engine bay and i disconnected the positive and negative terminal. I can;t remmeber what order I put them back on, but there is an order your suppost to put back on and I must of did it wrong. So all I did was disconnect the negative terminal again waited a minute and reconnected it and everything has been fine and dandy since then.

good luck!
 

·
Registered
Joined
·
277 Posts
Since you connected the negative terminal last and it worked, wouldn't that mean that you DO know the correct order? lol sorry had to point that out :rolleyes:

Lon
 

·
Registered
Joined
·
4,876 Posts
Yeah, if you have a Speed cal and the power is disconnected or the fuse for the cig lighter blows, you'll lose the speedo and the odometer/tripometer since the speedcal get's it's power from those...My fuse blew when a coin fell in my cig lighter outlet in my "Coin Tray", no longer used as an ashtray, and I lost the speedo...then as I would slow to stop the car would die...I think I read somewhere in a thread that the ECC kills the engine cause its not getting a signal from the VSS, or something to that effect...All I needed to do was replace the 30A fuse under the hood...
 
1 - 5 of 5 Posts
Top