Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi All and TIA for any and all responses,

My car is pretty heavily modified (429cid aluminum 4-bolt 351 stroker). It is carbureted and the computer has been removed. It uses a large Mallory electrical external fuel pump driven by a relay and the stock cooling fans are driven by a large 60A relay controlled by a Derale thermostatic unit. The ignition is an MSD HVC with MSD distributor.
I was pushing the car hard at Sears Point in a late model race at SAAC-43 last weekend and the engine just died 8^(. This is clearly not an engine mechanical problem since there are no signs of life electrically. Nothing turns on. There are no dash lights that come on when the ignition switch is turned on and, of course, the starter does not turn. The battery (new) seems to be OK with 12.7 volts.
Beyond checking the battery voltage, I have not checked anything else yet. I plan to inspect the following:

1) Fuses and Relays
2) Burned or shorted battery or starter cables
3) Fusible Links
4) Ignition Switch

I will follow the battery voltage to see where it stops. I was hoping maybe someone reading this will have run into this before and could provide a possible cause I haven't thought of yet.
I will read and appreciate every response.

Thanks, CobraRGuy
 

·
Registered
Joined
·
23,245 Posts
power in start and run, come from the ignition switch

power must then go from the battery, to fuses then to the switch

its pretty simple with a test light
 

·
Registered
Joined
·
23,245 Posts
why work backwards?
 
1 - 4 of 4 Posts
Top