Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
After getting my stang out of the body shop I noticed that occasionally my instrument cluster lights and shifter lights would not come on. I just messed with the fuse under the hood and then they worked. I thought that the fuse was just bad. I checked the fuse under the steering wheel and it was good. I checked the fuse under the hood and it was good. The fuse that goes to the instrument cluster also goest to the parking lights, which also aren't working. It also goes to the hood and trunk lights which are working. I have no clue as to what could be wrong. I just know that I can't be driving at night until I get this fixed. I didn't have this problem before I took my stang in to the body shop. Is it possible that when they were working on the fenders that they could have messed something else up? Any suggestions as to what could cause this. Oh, I almost forgot, the Airbag light is now flashing and staying on, it is also connected to the same fuse.
 

·
Registered
Joined
·
167 Posts
electrical are the worst to try and diagnose on a forum...too many variables. here is my guess..

sometimes the flashing airbag light is giving a trouble code. you should scan codes or watch the light and see if it is counting something out...

As for the lights....maybe the shop forgot to connect a ground wire somewhere...

maybe the lights and the airbag use the same ground that is not connected.

good luck.
 

·
Registered
Joined
·
1,790 Posts
Could be coincidence or poor workmanship from the body shop. Call them and see what they say. Seen stranger stuff happen.



Could be a dirty dimmer/headlight switch. Try some electrical cleaner sprayed into the staft seal. You should at least see a flicker.

I have lost the cluster lights and have a short somewhere as the fuse under the hood is good, but every time I replace the under dash, it pops. Let me know what you find.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
Thanks for the help everyone. I decided to check every fuse that I could find with no luck. I even replaced the good fuse under the hood with no luck. I also disconnected the battery for several hours to reset the computer with no luck.

watch the light and see if it is counting something out...
How would I know if it was counting something out? It does flash several times in what seems to be an orderly function before it just goes on for good.

I'm going to call the body shop in the morning and see if they will fix it. They are good people, so I bet that if they could have messed it up, they will look into it.
 
1 - 4 of 4 Posts
Top