Ford Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey y'all, long story short had a stall and idle issue. Went and bought a new IAC, but when I took the old one off and looked inside, the whole spring is missing. Took it apart and it was not inside the IAC housing at all.

Anybody else have this issue? Getting ready to pull everything apart and hunt it down to make sure its not in there
 

·
Registered
Joined
·
282 Posts
It might help if you mentioned the model year and engine of your Mustang.

Why might this be important? I can't recall ever seeing a spring inside the IAC of the 1996, 2000, and 2002 GT that I have owned.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It might help if you mentioned the model year and engine of your Mustang.

Why might this be important? I can't recall ever seeing a spring inside the IAC of the 1996, 2000, and 2002 GT that I have owned.
My bad. It is A 2002 GT. The new IAC I have has the spring and all in it. In the old one you can see where it is supposed to sit. I have personally never heard of one not having one. I thought that was what controlled the whole IAC
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Pretty much I'm trying to make sure either this new one is wrong, or that rod and spring are supposed to be in there, and if I need to tear it down and try to find it in the intake
 

·
Registered
Joined
·
698 Posts
are you sure the plunger and spring isnt just stuck and pulled all the way back in the old one? Ive never seen that piece fall out of any IAC. they are usually designed in a way that it cant fall out. the shaft is usually too long to fall out of the coil. Its even less likely the whole metal shaft fell out of the small hole.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
are you sure the plunger and spring isnt just stuck and pulled all the way back in the old one? Ive never seen that piece fall out of any IAC. they are usually designed in a way that it cant fall out. the shaft is usually too long to fall out of the coil. Its even less likely the whole metal shaft fell out of the small hole.
Yes I am sure. I took the whole unit apart and there was nothing in there
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #8
If that is the right way on the old one, I can see how it works shining a light through it and pushing down, the light gets blocked. But it would not make sense on why the new one has the whole rod
 

·
Registered
Joined
·
698 Posts
They do appear to be a different design but I cant tell from the pics
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
So I went to autozone and looked at what they had. Had a duralast in stock, and that one did not have the rod and spring. I'm having them bring in an Hitachi one that says its fors oem and if it does not have it I will get it.
 
1 - 11 of 11 Posts
Top