Ford Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
I have a C-4 in my car with reverse pattern, full manual valve body and a transbrake. Around a 2800 stall converter. My question is that when i am in 2nd gear, and let off the gas, it doesn't instantly decelerate (engine brake). It feels good when i am on the gas and doesn't seem to slip or anything like that at any other time.
First, is this normal? I had a C-4 in an old bronco i had, and it wasn't a comp tranny, but it definitely didn't feel like this on a decel.
Also, if it isn't normal, what should i check.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #2
I guess i should have also said, the main reason i wondered this also, is that when was really getting on the throttle, it puked some tranny fluid out. I checked the level and was a little over full. Would being over full cause either or both of these things to happen?
 

·
Registered
Joined
·
3,979 Posts
Are you sure it is when you are in 2nd gear and not when you are in first?
My old PA C4 and my current trans king C4 did/do it when I am in 1st gear. Basically you can romp it through the gears, then bump back to 1st quickly and it acts like neutral until it is down to where the speed matches the RPM of the motor. Not in 2nd gear though, 2nd gear decelerates normally.
 

·
Registered
Joined
·
2,097 Posts
Are you sure it is when you are in 2nd gear and not when you are in first?
My old PA C4 and my current trans king C4 did/do it when I am in 1st gear. Basically you can romp it through the gears, then bump back to 1st quickly and it acts like neutral until it is down to where the speed matches the RPM of the motor. Not in 2nd gear though, 2nd gear decelerates normally.
X2
Mine is exactly the same way.
 

·
Registered
Joined
·
1,192 Posts
same here. no worries.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #7
I know it isn't supposed to decel in first, its fine in that aspect. I am pretty sure i got it figured out.
I think when the fluid would foam up from being over full, it would puke and also cause the decel problem in 2nd. Once i ran it hard for a while and puked most of the extra fluid out, it works fine now.
thanks for the inputs.
 
1 - 7 of 7 Posts
Top