Ford Mustang Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
2,098 Posts
Discussion Starter #1
It was a pedal fest all night long. Having the new car blues, trying to get the car to hook. The last pass of the night started to come around, but we are not there yet. Best 60' was a 1.58 still backing out of it off the hit and getting back in it. We did not have time to take the 4.10's out, so I had to lift just before the 1000' cones, still went a [email protected] with the 275-50-15's
 

·
Registered
Joined
·
7,030 Posts
The last pass the front of the car looks better. The rear is doing something funny. need to plot it out and see what you have. The inital hit looks good but it falls appart from there.
 

·
Registered
Joined
·
3,979 Posts
Not a bad first outing. Slap a 28" tire on it and see what happens.
 

·
Registered
Joined
·
711 Posts
whats the engine combo? tranny/converter.
 

·
Registered
Joined
·
2,098 Posts
Discussion Starter #11
Craig, it went just shy of 100 mph in the 1/8th. It still has your old suspension in the rear, un-touched. Still exactly the same as the day I brought it home. I just thought I would give it a try. Use it as a baseline before all the Team-Z stuff goes in and the 3.55's. OH, I do have a maximum motorsport rear anti-roll bar in it now.

Cal, whats the 1/8 times, mph ?
 

·
Registered
Joined
·
7,198 Posts
Need a 28" tire on there. I've gone 126 in the 1/4 trapping at 6,300 rpms....with a 28" tire.
 

·
Registered
Joined
·
2,098 Posts
Discussion Starter #13
With a stick I can see doing that, but I am looking for 132mph trap speed. With a converter in there, I need more gear. The 28" tire would help a lot, but I don't want to run the 28" tire in this car. It is just too much messing around I.E fender clearance, tails pipe clearance, blah blah. The 50's are staying.



Need a 28" tire on there. I've gone 126 in the 1/4 trapping at 6,300 rpms....with a 28" tire.
 

·
Registered
Joined
·
3,979 Posts
With a stick I can see doing that, but I am looking for 132mph trap speed. With a converter in there, I need more gear. The 28" tire would help a lot, but I don't want to run the 28" tire in this car. It is just too much messing around I.E fender clearance, tails pipe clearance, blah blah. The 50's are staying.
Well then the 3.55s should do the trick!
 

·
Registered
Joined
·
669 Posts
need to do something with the hatch, first video its moving around on launch.
 

·
Registered
Joined
·
2,098 Posts
Discussion Starter #16
Yah I need to get the frickin thing to latch :pain: I messed with the striker before going to the track, thought I had it latching, but then discovered it was coming un-latched again. I need to have Tim come over and help me line it up.


need to do something with the hatch, first video its moving around on launch.
 

·
Registered
Joined
·
7,198 Posts
With a stick I can see doing that, but I am looking for 132mph trap speed. With a converter in there, I need more gear. The 28" tire would help a lot, but I don't want to run the 28" tire in this car. It is just too much messing around I.E fender clearance, tails pipe clearance, blah blah. The 50's are staying.


I'm with you man. I missed the automatic part...and I can't hear the sound in the video's at the PC I'm at today. :livid:

Gotta love these 400" windsors though!!!
 

·
Registered
Joined
·
205 Posts
Craig, it went just shy of 100 mph in the 1/8th. It still has your old suspension in the rear, un-touched. Still exactly the same as the day I brought it home. I just thought I would give it a try. Use it as a baseline before all the Team-Z stuff goes in and the 3.55's. OH, I do have a maximum motorsport rear anti-roll bar in it now.
Props man you've did a lot of work and very nice work at that! Do you know if the pinion angle changed any from the k-member and trans change? I realize you have better rear suspension pieces to go in, but the bottom hole might work better for you in the LCA with the auto.
 

·
Registered
Joined
·
2,098 Posts
Discussion Starter #19
I am sure the pinion angle did change, since I put HPM drop mounts in it and lowered the k-member 3/4" The engine trans sits in the car level now, but I am sure the out-put shaft angle to pinion has changed. I talked to Dave today, he told me it was hitting the tires too hard for that much power, that the SR's have too much anti-squat. Like I said, I really have not touched the rear yet, since I will be replacing it all probably Monday. Then we will square it up, and plot it out.

I also need to try a 3923 plug instead of the 22's. I think they are too cold and causing my high timing issue.



Props man you've did a lot of work and very nice work at that! Do you know if the pinion angle changed any from the k-member and trans change? I realize you have better rear suspension pieces to go in, but the bottom hole might work better for you in the LCA with the auto.
 

·
Registered
Joined
·
269 Posts
Nice looking car.

What's your limiter at? With lockup in 3rd I would think 4:10's would be close. I was going thru the traps about 7k with about 8% slip @ 130. I
 
1 - 20 of 23 Posts
Top