Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
Well heres the deal. I have a problem with my boost spiking all the sudden. It never used to do it, but now i guess it does. I have a gt40 302 with canfield heads and mpt70 3"cold side with intercooler and 3" hotside, also a 38mm wastgate mounted were the two hotside pipes merge. Wastegate also has a 10lb spring in it. Now the problem. All summer long it would boost ta 10lb and stay there, now it will boost to 10lb till about 4800rpms and then climb till I lift. By 5500rpms Im up to 15lb and havnt gone anyfarther. The only thing ive changed was I put a new fuel pressure regulater on and some fuel rails. Nothing to do with the turbo? Does it sound like mabey the wastgate is going bad? Thanks guys.....
 

·
Registered
Joined
·
4,744 Posts
triple check your vac line going to wastegate.
if it has a small leak the wastegate wont see correct psi.

good place to start.
 

·
Registered
Joined
·
1,006 Posts
Don't know what to tell you honestly, never figured it out. Had the exact same thing happen to 3 of my cars. One day, one boost level, months later mine went from 12 to 14, another 9 to 15 and one more 12-17. All 38mm Tials. Their advice was "it should have a 44mm on it." That didn't explain why it was working, then stopped. help stopped on their end, and purchasing Tial stopped on my end. I have fixed one 38mm gate problem with a 40mm JGS gate. Went from 13psi to 9
 

·
Registered
Joined
·
190 Posts
Discussion Starter #4
I think that is what im going to do. Im going to do some looking and upgrade my waste gate. It just doent make any sense why it was working great for so long and just like that it wants to raise boost? Well thanks for the input guys.
 

·
Registered
Joined
·
4,744 Posts
It may just be dirty. A cheap seal and lube rebuild may make it work like new.
The things are exposed to a pretty harsh environment.
 
1 - 6 of 6 Posts
Top