Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
Working on a car that runs 10:1 comp, 29 PSI boost, no intercooler, 116 oct, MSD DIS4, Denso's, and it uses an EDIS with stock coils. The ignition has caused me alot of grief. I have tried too many things to list to fix it. I have it bandaided for now. I also have another plan to fix it properly, but I think this would be a cool topic of discussion. Anyone have something to share? Oh by the way here is one of my my ideas. Use a crank trigger and a Speed Pro (FAST) DIS module to drive the DIS4 to drive the MSD High output GM(AC DELCO) twin tower coils. This system should handle 8500 rpm and put out 50kv or 135 Millijoules. I talked to an engineer at MSD and he was very helpful. His knowledge of igniton systems left me feeling like I had "Forest Gumped" my way this far. He set me up with a new product and I want to tell you guys about it as soon as I can. I know that the electromotive system works well for us modular guys, but I like knowing all the alternatives.
 

·
Registered
Joined
·
1,136 Posts
Good grief 29 psi on 10:1 with no intercooler. You've just stepped on a landmine, don't raise your foot! :) j/k Wow is all I can say.
 

·
Registered
Joined
·
168 Posts
So what exactly is your idea?
Correct me if I'm wrong you are basically saying use a FAST system which uses the EDIS module to fire the coil packs.And then on top of that the DIS 4 to bump up the spark.
If so that works very well but you will still stop spark output around 8500.
What new product did MSD tell you about.Their coil packs?Or something else?
 

·
Registered
Joined
·
159 Posts
Discussion Starter #5
LMSwest said:
So what exactly is your idea?
Correct me if I'm wrong you are basically saying use a FAST system which uses the EDIS module to fire the coil packs.And then on top of that the DIS 4 to bump up the spark.
If so that works very well but you will still stop spark output around 8500.
What new product did MSD tell you about.Their coil packs?Or something else?
I want to pitch the EDIS and use the DIS module that FAST sells. The crank trigger has less signal degredation than a stock "36 - 1" sensor at higher RPM, from what I have seen with the scope.Besides, the EDIS gets confused as low as 7900 RPM. The stock type coils also have "cross over". I think it's because they share a common 12 volt + potential between two coils in very close proximity. If you look at the signal at the coil with a scope you can see an "echo" from the other coil. I think that 4 seperate twin towers would work better.
The system MSD sent me is a high output version of their CPC system. 8 coils with 157 mj potential. I would love to find out what those Indy guys are using. I've heard they run COP , and they are running 40PSI turbo boost.
The only problem with the MSD is that I will have to make a cam sync. I can't use the stock cam sync for a couple reasons.
 

·
Registered
Joined
·
1,964 Posts
Scott if you are using ACCEL coil packs and or MSD plug wires ditch them. Stock coil packs are better. Last year I had no ignition problems until I hit 8000 rpms with Mark VIII EDIS. At that point the EDIS would get confused. I also ran Dis 4, Champion YS plugs, and motorsport plug wires. I ran C16 fuel. My personal preference is electromotive. It's the strongest ignition your going to find.
 

·
Registered
Joined
·
159 Posts
Discussion Starter #7
I tried stock and Accel coils, but I only used MSD wires so far. Maybe we'll try the Ford ones. Thanks for the input Dave. Some racers are afraid to tell you what works and what doesn't. I think that the people that are confident in their abilities and their cars are the quickest to share info. It makes the sport that much more enjoyable. What gap are you running on the champs?
 

·
Registered
Joined
·
159 Posts
Discussion Starter #9
She's runing a DFI, thanks anyway. I was using the champs and I started them at the same gap as you, but I had to work them down to 20 thou to get them to work half a$$. The Denso's worked better on our combo. You sure got you're setup working nice by the way.
 
1 - 9 of 9 Posts
Top