Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
For some reason, I can't post on TM.com's new forum and since most of the guys who hang there are here, too, I'll post it here.

Sunday, I finally picked up the Turbo Engineering kit I should have picked up the weekend I flipped my truck. Everything looks great! The turbo (60hifi) has just been rebuild and the center section still has the "toe tag" on it. It has zero miles on it, never even been installed. It has a .96a/r turbine housing. Kit came complete with headers, crossover, Deltagate, downpipe, intercooler, oil feed and drain lines, brackets to install the Jabsco electric pump (which will be tossed in favor of a Mallory 110 pump), various hardware and even an exhaust system he had made up by a muffler shop. It isn't much of an exhaust system, a 3" pipe that connects to the downpipe to a muffler which dumps in front of the rear axle. I plan on running the 3" pipe into a 2.5" catback system, though. I want the dual tailpipe look. May even use stock tailpipes for the sleeper look.;)

I plan on seding the headers, crossover and downpipe to be ceramic coated. I will probably install the kit as is, though, just to work out any bugs before they are coated. Figure get the car running for now and send the stuff out to get coated. Install the coated headers, etc., with the heads (probably Twisted Wedge) later on. Now, it's time for a set of injectors, MAM and pump.
 

·
Registered
Joined
·
325 Posts
Take some detailed pics of that setup, seein that is like see'n the locke ness monster, people say its there but is it really?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I'll take pics as soon as I get the chance.

I did re-register with the new board, still no luck. It has me logged in as a member, but I can't post. Also doesn't have me listed as a member in the member list.:confused:
 

·
Registered
Joined
·
1,239 Posts
Eddie, have you tried to get a hold of Trent or Eddy to see if they can fix the posting problem?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Problem solved. Thanks, Trent.:)
 
1 - 6 of 6 Posts
Top