Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter #1 (Edited)
You guys with the HP Performance kits,where are you mounting your wideband bung in the down pipe?

Also the IAT,where are you mounting that in a 94-95? I had it before TB on my Vortech
Thanks
 

·
Registered
Joined
·
361 Posts
Discussion Starter #2
Guess no one is running an HP Performance kit then?? :)
 

·
Registered
Joined
·
1,274 Posts
I have 3 bungs down near my bellhousing. One for wideband, two for narrowband. You don't want the wideband too close to the turbo outlet.
 

·
Registered
Joined
·
361 Posts
Discussion Starter #4
I have 3 bungs down near my bellhousing. One for wideband, two for narrowband. You don't want the wideband too close to the turbo outlet.
Do you have your wideband bung before the 02 bungs or after?
 

·
Registered
Joined
·
1,274 Posts
They are all essentially in the same spot. Here's a picture when I was mocking everything up. The wideband bung in shown. The other two are on the opposite side of the pipe.

 

·
Registered
Joined
·
470 Posts
so nobody would suggest running one on each bank. I run aem ems and was thinking right after my headers tube merge into each crossover b4 turbo. it's a twin scroll turbo so I will have sep tubes to turbo.
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
so nobody would suggest running one on each bank. I run aem ems and was thinking right after my headers tube merge into each crossover b4 turbo. it's a twin scroll turbo so I will have sep tubes to turbo.
Do a search on this. There have been experiences of failure of 02 sensors when in the hotter higher pressure scenario of the hotside pre turbo.
 
1 - 8 of 8 Posts
Top