Ford Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
224 Posts
5psi, if you make more your gates arent big enough and it will creep. I have twin deltagate mark II's on mine with twin t-70s, and can run as low as 3 psi without problems.

Anthony
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
i'm getting boost creep then. i have hellions twin 61's on my 96 cobra with 5 psi spring in each waste gate they are turbonectics evolution 35mm for each turbo. i almost creep to 10 lbs any ideas??

i called hellion and decribed wat was going on and how boost was slowly climbing to almost 10lbs they told me eveyrhitng sounds rite that seems normal on a turbo car.
 

·
Registered
Joined
·
4,744 Posts
i'm getting boost creep then. i have hellions twin 61's on my 96 cobra with 5 psi spring in each waste gate they are turbonectics evolution 35mm for each turbo. i almost creep to 10 lbs any ideas??

i called hellion and decribed wat was going on and how boost was slowly climbing to almost 10lbs they told me eveyrhitng sounds rite that seems normal on a turbo car.

Thats not normal, if you have 5psi springs it should make 5psi.

Dont know if its an issue with Hellion or just you though.
 

·
Registered
Joined
·
3,209 Posts
It sounds to me that you're exhaust housings are on the big side...and what you are experiencing is turbo lag, not creep.

Those wastegates likely have a 10lb spring in them for the above to happen.

What a/r is you're exhaust housing with those 60-1's, and what is you're rear end gear ratio?
 

·
Registered
Joined
·
61 Posts
Discussion Starter #8
hellion says there .63. im going to get under the car later and check for sure. there are 5 psi springs in the waste gates i put em in there. rear gear is 3.27.

she'll make 5 lbs about 4k hold there for a second then creep 6......7.....8....9 and by redline ill be just about 10.
 

·
Registered
Joined
·
3,209 Posts
hellion says there .63. im going to get under the car later and check for sure. there are 5 psi springs in the waste gates i put em in there. rear gear is 3.27.

she'll make 5 lbs about 4k hold there for a second then creep 6......7.....8....9 and by redline ill be just about 10.
If that's the case....then it sounds like a possible vacuum leak on one or more of the wastegate lines.
 

·
Registered
Joined
·
224 Posts
Honestly, i think your gates are too small. What happens is, your gates can't release enough air to keep it at 5psi, and your boost starts to "creep". Both of my gates are 38mm. My gates are known to boost creep also, but i don't have a problem http://www.homemadeturbo.com/forum/index.php?topic=63976.msg740603 I don't think you are the only person with problems with those gates. I am not saying to go out an buy new ones. Look for other problems. If your gates are too small i would check out the turbosmart ultragates or the jgs gates, both quality pieces!

Anthony
[email protected] with a 1.950 60'!
 

·
Registered
Joined
·
3,209 Posts
Honestly, i think your gates are too small. What happens is, your gates can't release enough air to keep it at 5psi, and your boost starts to "creep". Both of my gates are 38mm. My gates are known to boost creep also, but i don't have a problem http://www.homemadeturbo.com/forum/index.php?topic=63976.msg740603 I don't think you are the only person with problems with those gates. I am not saying to go out an buy new ones. Look for other problems. If your gates are too small i would check out the turbosmart ultragates or the jgs gates, both quality pieces!

Anthony
[email protected] with a 1.950 60'!
5psi is a very low pressure...so it too is possible. The easy fix is simply to up the boost and see it goes away. ;)
 

·
Registered
Joined
·
4,744 Posts
Twin 35's should be plenty big.

What kind of mufflers are you running ?
Wondering if maybe you have high post turbo back pressures.
 

·
Registered
Joined
·
224 Posts
millhouse has a great idea. Get that fuel system on there and try it out. R.bsrn is also correct. The only problem is is that all wastegates aren't designed the same. Even though twin 35's SHOULD be enough, if the design doesn't allow that much air to be relieved you can run into problems like this. I have seen some guys run into problems like this, and they switch wg brands and keep the same size as the previous gate, and the problem goes away. Hope you get this figured out. Also check out theturboforums.com, there is a lot of info over there!

Anthony
 
1 - 15 of 15 Posts
Top