Ford Mustang Forums banner

1 - 20 of 26 Posts

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #1 (Edited)
Need a little help. Just really getting into racing at the track.


90 Coupe.
3150 full race weight
Turbo
Powerglide
3.27's
ARB
All solid aftermarket suspension
Stock mount viking coilovers
Strange 10 ways and coilovers up front.
Ultimate converter concepts TQ Converter.
28'' Hoosier Slick
810 to the tire




Two time slips for you guys.

#1
60 - 1.397
1/8 ET - 5.917
1/8 MPH 119.16
1/4 ET - 9.200
MPH - 149.50

#2
60 - 1.426
1/8 ET - 5.923
1/8 MPH 119.93
1/4 ET - 9.190
MPH - 150.30


Never really spent to much time on adjusting the suspension besides base settings. Just put the ARB on. 60's improved some. Just looking for some direction. MPH should be good for high 8's no?
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #2 (Edited)

·
Registered
Joined
·
626 Posts
Where do you race at? There aren't even scoreboards for times.

I can't help you with your 60's, but you car runs like a bat out of hell!
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #4
I race at a small local track lol. Thanks.
 

·
Registered
Joined
·
2,682 Posts
where are the shocks and struts set?
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #6
Front on the 10 ways is 3 or 4 i think. The rear compression is at 4 and reboud is at 5.
 

·
Registered
Joined
·
103 Posts
My combo is way down on power compared to yours, and im a footbrake guy, so this info might not be any good to you.

The tighter i set my front 10 ways, the faster my 60 gets, up to the "#8" setting...Thats with 12" 150lb coilovers

I have my rear shocks (cheap 3 ways) at 50/50

Pinion angle -3

stock GT rear springs cut enough to get the rear lower control arms as close to parallel with the ground as possible

I 60ft high 1.3s, low 1.4s with a bit over 500 @ the flywheel, through a c4 thats flashes to 3300

Hope this helps
 

·
Registered
Joined
·
2,682 Posts

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #9 (Edited)
From full loose on all the settings posted. Running a 14-175 up front.
 

·
Registered
Joined
·
2,682 Posts
really hard to see in that video but have you tried tightening up the compression on the rear shock any? it looks like it hits the tire good but it bounces back and unloads the back of the car some.
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #11
I have increased it up some compression and rebound to the settings above. Still was hooking good. Should i try to get the rear dialed in first by increasing the setting untill i cant hook then backing off. Then adjust the front or what?
 

·
Registered
Joined
·
2,682 Posts
how much air pressure are you running?

best thing i can suggest is always get video of every pass and just watch it and see what its doing. and the closer and clearer the video the better. slo-mo is also your friend!
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #14
Ok. So basically i want the front to come up slower and use that energy to propel the car forward quicker? All while getting enough weight transfer to help plant the rear tires?


Should i go to about 6-8 on the front and try that out?



Really appreciate all the help.
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #16
Crossing at 6600 already
 

·
Registered
Joined
·
103 Posts
Ok. So basically i want the front to come up slower and use that energy to propel the car forward quicker? All while getting enough weight transfer to help plant the rear tires?


Should i go to about 6-8 on the front and try that out?



Really appreciate all the help.

Yes, thats what worked well for me. I gained right at a tenth in my 60 just changing the front strut settings
 

·
Registered
Joined
·
407 Posts
Nice car.

I agree with slofox, it looks like the front end is rising too quickly and then hitting the front end travel limiter too hard.

This momentarily unloads the rear tires when the front hits the limiter, which can cause some tire spin.

Before it hits you are getting good weight transfer but then when it hits hard it temporarily reverses the weight transfer, unloading the rear tires in the process.

Try going up in stiffness on the front struts 2 clicks at a time, checking the 60' as you go.

With your MPH the car is showing the car can do a 8.9 or so ET, with a 60' around 1.24 or so.

What kind of rear ARB are you running? (and I'm assuming the front ARB is long gone).
 

·
Registered
Joined
·
2,366 Posts
Tire pressure?

Hard to tell but I didn't see much sidewall wrinkle. The rear did remain neutral so your AS is good. Yeah the nose came up a hair too quick but I honestly think it was already in a spin before the struts topped out.

-Mark
 

·
Premium Member
Joined
·
1,485 Posts
Discussion Starter #20
Tire pressure was at 15psi. I had trouble with spinning and overall my 60 decreased when launching at 5500. Sweet spot was at 5000 and tires at 10-12 psi. There is a good bit of wrinkle on the video i watched on the go pro. I am running a stiff wall slick. No problems hooking up.
 
1 - 20 of 26 Posts
Top