Ford Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,738 Posts
Discussion Starter #1
In May my turbo seal blew, had it rebuilt and it blew again, rebuilt it again and it blew. Found out the problem was probably my oil separator was plugged up so the crankcase pressure really built up. I removed the spectator and put it back to stock. Put the rebuilt turbo back in and now the impeller has allot of movement, and puffs of smoke when closing the throttle. Well now I'm paranoid, I purchased a new turbo today upgraded from a 67 to a 76mm. Is it possible that my 67 was just trashed? Anyone else ever have a problem like this?
 

·
Registered
Joined
·
3,318 Posts
Is it possible that my 67 was just trashed?

I find it REALLY hard to believe its the turbo. its has to be something OTHER then the turbo to kill a new percision turbo and 2 rebuilds. check what Jay and Tbird said first.


Do you have enough crankcase vent? Under boost the blowby can back the drain up and it will smoke on decel. Also how good is your drain?
Jay, you might not rember me (you were pretty busy that day) but my name is Jason, I stoped in your shop last month with Kris Starnes when he picked me up in Orlando. Just wanted to say thanks. everyone was really cool and I had a good time. something Im NOT useto anymore living here in Ohio lol ALL the shops here are twice as rude/cocky and their quality is less then half of what you guys put out.


When I drive down to visit Kris again I will be in for a tune. Flying through what was left of that hurricane scared me I will be driving from now on lol
 
1 - 4 of 4 Posts
Top