Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
Just finished my quicktime turbo setup, and let me say this is one awesome kit, well worth the wait. I am going for a tune this Sat. I got a chip with a base tune so I could get it running and get all the fluids checked. One problem that I am seeing is when I rev it up the fuel press. is dropping from 39 to 30 or 31. But when I pull the vacuum line off the fpr the fuel press. stays at 39 when I rev it up and idleing. The vacuum on my boost gauge is going from about 8 at idle to 15 or 20 when I rev it up. The farthest I am able to rev it is about 3500. I don't want to drive it yet since it isn't really running very well because of the tune that is on this chip. I have a aeromotive fpr that I bought new last year, and a 255 holley forced induction fuel pump that I put in new to years ago, I have only put about 2000 miles on it since changing fuel pump. Any Ideas why my fuel press is dropping?
 

·
Registered
Joined
·
304 Posts
I have a similar setup as you. I believe the vaccum on my boost gauge is close to 15 at idle. I also have my AFPR vaccum hose going directly to the intake . Im not an expert but im goin to guess vaccum leak?....
 

·
Registered
Joined
·
5,957 Posts
Something is a little funny. When you rev the car, the vacuum should go towards zero, not to increased vacuum.
The key is you do not want fp dropping under load. I lifted the heads doing that when my fuel pump was dieing.
Erich
 
1 - 3 of 3 Posts
Top