Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
92 mustang 5.0

Tach worked great prior to putting in new distributor (spectra complete from oriellys). Now tach bounces around and is definitely not reading correct. I will be going back through engine grounds to make sure nothing loosened up. Haven't driven car due to weather but likely will tomorrow. Had a high rpm/load stutter that is why I put in new distributor/new ffrp wires/new plugs. Re adjusted rockers since they a little too loose. Car sounds great and revs nice just tach is acting up. Wonder on what you guys think it might/could be.

specs:
tw170 heads
f303 cam
systemax 2 intake
70mm tb
bbk cold air
pro-m meter
24lb accel inj

-tps volts .95, iac newer with new adjuster plate
 

·
Registered
Joined
·
1,803 Posts
Usually people have trouble with Non-Ford Distributor Electronics. If it was me, I'd probably swap the whole dizzy out for the old one but use the new rotor/cap with new wires. Or I'd swap the TFI module back to the old one and see if that fixes it but it requires the dialectric grease and cleaning so maybe not quite as easy.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #4
well the old one I had a 1 yr msd cap and rotor. so idk maybe do the tfi swap I guess but we will see hope to drive it tomorrow and see if runs better or not
 

·
Registered
Joined
·
198 Posts
Discussion Starter #6
Yah car has a terrible miss, like it just falls on its face and bucks at any load, but idles great revs nice in neutral. Thinking I have vacuum leak, weak coil, something going on. I cleaned mass air already, adjusted tps, tried timing at 18* and 14* actually got a little worse at 14*
 

·
Registered
Joined
·
23,235 Posts
misfires, will cause tach to jump
 

·
Registered
Joined
·
23,235 Posts
especially if you have a sec open, and the coil is NOT allowed to discharge to a ground

you will destroy the coil pretty quickly
 
1 - 8 of 8 Posts
Top