Ford Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter #1
My build is on3 turbo for 5.0 with upr kmember with coil over. I took the motor out installed the upr kit and im trying to lower the motor with turbo header bolted on into car. Im running into i bunch of problems now. If i put the mounts into rear slots of kmember the down pipe hit the rack. if i put the mounts in front slots you cant get the motor mount nuts on because of rack, also downpipe is very close to rack(def gonna cook boot). anyone out there running this setup? any advise. ive tried stock mounts and conv mounts(in both slots) but same problem. nothing is fitting right.....
 

·
Registered
Joined
·
2,937 Posts
take the headers off and get the motor in and all hooked up. Then install the kit
 

·
Registered
Joined
·
131 Posts
I am running this setup, stock style engine mounts, and I a 7 quart canton oil pan. I would also suggest running the drop bushings for the rack. I also had to make spacers for my K-member and drop it down over half a inch in order to get everything to clear properly. I agree with mazda-sped get the engine in and then put the headers on.
 

·
Registered
Joined
·
257 Posts
Discussion Starter #8
Thanks for replying. I finally got it once I had more daylight. The rack because new from parts store was made little different so I had to pull it out a little to tighten it all up. Also was able to straighten out the motor once I could see good. Once all that was done I everything to fit nice. I am going to get those bushings as well, that ks for tipThanks again

Sent from my DROID RAZR using Tapatalk 2
 
1 - 10 of 10 Posts
Top