Ford Mustang Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
911 Posts
Discussion Starter #1
well today i decided to fire up the car.
at all cases it did the same thing .fired up worked fine but after the first wot blast it went mega rich.

well i opended up the hood to TRY to diagnose the problem thinking that it was the maf clogged or something anyway i notoce that there was coolant spilling slowly from the radiator cap.

then i remeber my friend mavi99gt had the same problem they diagnosed ity and found the thermostat.

since white smoke was coming from the air breather hose,the temp of the cae suddenly rising i too think it is the thermostat.

since i drive the car 1per 2 weeks do you think that the thermostat corroded and the temp sensor sends the code to the eec that the engine is running hot which ends up in the timeing being pulled?my gauges aren't working well right now (i am fixing it right now) i can't tell wether the car is running hot or not but i do have to admit that it's temp is rising way faster than usual.
 

·
Registered
Joined
·
1,724 Posts
I remember you saying you had a hole in your valve cover. Did you find out what caused that? A stuck stat will cause overheating and corrosion can cause that. If you are using a quality coolant you should not have corrosion though. From the sounds of things I would be doing a compression test on all cylinders and pressurize your cooling system to check for a blown head gasket.

Good luck, Dwayne
 
1 - 2 of 2 Posts
Top