Ford Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,390 Posts
Discussion Starter #1
I am concerned about the temperature my car is running. This is my first turbo and I feel that it is running a little higher than I would like. What Temps do you see when at cruising speed and how high after a hit? Thanks in advance for replying.
 

·
Registered
Joined
·
1,803 Posts
low boost 306 here. I have a 180 thermostat that and car usually runs/cruises around 185. low boost hits bring it up to 190-195 then back down soon after. this is in the houston Texas heat and humidity
 

·
Moderator
Joined
·
4,310 Posts
So many variables come into play with this, especially due to overall design of how you did your cooling system but also keep in mind placement of intercooler and so on. My last car was similar to the prior user in regards to temps and I too am in Houston. One thing is for sure make sure you have a good well working temp gauge. The 93 GT over at my place right now is not boosted but regardless the factory gauge or sending unit on it is foo barred because if I were to trust it the car is running WELL in the 200s and it has zero performing signs of that happening.
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #4
So many variables come into play with this, especially due to overall design of how you did your cooling system but also keep in mind placement of intercooler and so on. My last car was similar to the prior user in regards to temps and I too am in Houston. One thing is for sure make sure you have a good well working temp gauge. The 93 GT over at my place right now is not boosted but regardless the factory gauge or sending unit on it is foo barred because if I were to trust it the car is running WELL in the 200s and it has zero performing signs of that happening.
I can monitor from two different sources and gauges and both are reading within 1 degree. .
 

·
Moderator
Joined
·
4,310 Posts
What two sources were you able to go off of and get that close of temp readings? I always got much hotter readings going off ports on the back of the intakes v. the fronts. Then as I recall any time I tapped into the t-stat housing for a sensor I would still see a difference between it and the others. Not doubting you, just curious.
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #6
What two sources were you able to go off of and get that close of temp readings? I always got much hotter readings going off ports on the back of the intakes v. the fronts. Then as I recall any time I tapped into the t-stat housing for a sensor I would still see a difference between it and the others. Not doubting you, just curious.
My mistake. One sensor. Gauge in the holly dash and digital gauge.
 

·
Registered
Joined
·
636 Posts
I fought this with mine also with a stock style cooling system.I added a air dam under radiator,hi flow pump,removed t stat,but the thing that helped the most was a cobra water pump pulley. if your car has under drives on it throw them away..also has a new alum 2 core rad. with ford contour fans.
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #8
I fought this with mine also with a stock style cooling system.I added a air dam under radiator,hi flow pump,removed t stat,but the thing that helped the most was a cobra water pump pulley. if your car has under drives on it throw them away..also has a new alum 2 core rad. with ford contour fans.
I am running a 2 core aluminum radiator with a electric radiator mount 55gph pump that has 2 12an lines to the front of the motor and 16an return to the radiator and no thermostat. So there are no pulleys.
It is getting better but still a little warm. I am going to try to find another fan that will fit but room is at a premium. Thanks for the reply though.
 

·
Registered
Joined
·
4,154 Posts
If you have room put a 3-core in it.

ks
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #10
If you have room put a 3-core in it.

ks
I wish I had room but it will take some re-fabrication of all of the mounts for the radiator and intercooler and the cold side tubing would all have to be refabed. I also forgot to mention that it is a dual pass rad. Thanks and keep the ideas coming. Sooner or later something is going to be doable.
 
1 - 10 of 10 Posts
Top