Ford Mustang Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter #1
Just reinstalled freshly built engine in my 97 cobra. Finally got all the gremlins sorted out and car idling good. Only issue now the electric fan isn't working at all. Tried a known good ccrm and same results. Ran power to fan and verified it was good. Read somewhere by removing the ect connector fan should cycle with key on, but isn't in my case. Tried a/c and defrost settings and still no fan or voltage at fan connection. Not sure if a/c needs to be charged in order for that test to work anyway. All fuses also checked good. When I first turn the key to the run position I can occasionally see the fan bump over an spin just for a second. With the car up to temp still no fan. I looked at ccrm schematic and verified voltages at correct locations. By looking at schematics it looks as if pin 14 or pin 17 on ccrm need grounding from pcm. I tried grounding pin 14 on ccrm with no luck. I was going to try pin 17 ,but it's showing battery voltage on it? Any advice would be greatly appreciated. Thanks
 

·
Registered
Joined
·
22,414 Posts
using test light to ground

ground pin 28, low speed, and 46 high speed, with key in run, you can leave the ecm connected

report what happens.
 

·
Registered
Joined
·
363 Posts
Discussion Starter #6
Done as you described but used pin 14 and pin 17 at ccrm. Pin 17 has 13.86 vdc to pin 14. Thanks
 

·
Registered
Joined
·
22,414 Posts
I don't need a potential reading, we need to supply a ground

those volt readings MEAN NO ground is supplied, its open.

My test verifies relay integrity
 

·
Registered
Joined
·
363 Posts
Discussion Starter #9
I'll have to purchase a test light tomorrow. Pretty much your wanting me to go from pin to pin with each end of test light? Thanks
 

·
Registered
Joined
·
22,414 Posts
test light clipped to ground, verify good ground.

the other end, backprobe the pins while the key is in run

what do you think should happen when you do this?
 

·
Registered
Joined
·
363 Posts
Discussion Starter #11
As long as there is power on the relay this should ground the negative side of the coil.
 

·
Registered
Joined
·
363 Posts
Discussion Starter #14
Got a test light and probed wires as directed. Actually wires are pin 45 &46 on pcm. When probing pin 46 for high speed the CR closed and fan ran on high. Pin 45 there wasn't any change.
 

·
Registered
Joined
·
363 Posts
Discussion Starter #16
Yes. That was incorrect. Ohms back from pin14 on ccrm to pin 45 on pcm and verified. Chilton manual also confirmed pin 45 and 46. Thanks
 

·
Registered
Joined
·
363 Posts
Discussion Starter #17
Here's the pcm pinout. Schematic is on down in the discussion. Thanks. forums.tccoa.com/7-engine-4-6l-5-4l/142339-96-cobra-pcm-engine-harness-94-bird.html#/topics/142339?page=1&_k=gcfulc
 

·
Registered
Joined
·
363 Posts
Discussion Starter #19
I tried linking it without any luck. I have to copy and paste it in browser to get it to open. It's the complete pcm pinout on the 96. It shows the pin 45 & 46 as being correct. Thanks
 

·
Registered
Joined
·
22,414 Posts
unplug the fan

redo 45 with the test light

check for voltage at the low speed wire that you unplugged from the fan.
 
1 - 20 of 27 Posts
Top