Ford Mustang Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
568 Posts
Discussion Starter #1 (Edited)
I dynoed my car last night and much to my shock there was a huge lean spike from about 4000 rpm to 4300 rpm. It got as high as 17.5:1 :eek: My heart stopped when I saw the air fuel spike like that but before I had a chance to really react ther air fuel came down instantly. Does anybody have a clue as to why this happened? Here's the dyno run......

Bottle run is in blue.

 

·
Registered
Joined
·
1,076 Posts
N20 is a OXYGENATE. It adds a cool charge of O2 to your motor. Air.

I'm assuming your computer adusted this sudden condition by adding more fuel. Thus correcting your a/f.
 

·
Registered
Joined
·
568 Posts
Discussion Starter #3
I know how nitrous works :rolleyes: . The thing I don't understand is why it spiked so extremely lean 1000 rpms after the initial hit.
 

·
Registered
Joined
·
362 Posts
Mine did the same thing Jomar. Some people said that it shocked the computer and it compensates by adding more fuel. I'm gonna add a boost a pump to see if it can correct that sudden spike. Do you have a larger in tank pump? I have a 255 and I'll see what the BAP does for me. I have a link at home to rewire the fuel pump, I'll email it to you if you like.

Neal
 

·
Registered
Joined
·
2,335 Posts
SNK BITN said:
Mine did the same thing Jomar. Some people said that it shocked the computer and it compensates by adding more fuel. I'm gonna add a boost a pump to see if it can correct that sudden spike. Do you have a larger in tank pump? I have a 255 and I'll see what the BAP does for me. I have a link at home to rewire the fuel pump, I'll email it to you if you like.
Neal
Isnt that graph the scary same Neal! Looks identical.... maybe it has to do with a 150+ shot setup and the eec flipping out?
 

·
Registered
Joined
·
1,462 Posts
Could you give us some more details about your setup? What kind of kit is it? What mods do you have?
 

·
Registered
Joined
·
568 Posts
Discussion Starter #7
SNK BITN said:
Mine did the same thing Jomar. Some people said that it shocked the computer and it compensates by adding more fuel. I'm gonna add a boost a pump to see if it can correct that sudden spike. Do you have a larger in tank pump? I have a 255 and I'll see what the BAP does for me. I have a link at home to rewire the fuel pump, I'll email it to you if you like.

Neal
Really?! Man, thats some ****. At least I know I'm not the only person having this same problem. I have the NOS 5171 kit and I only have the inline pump that was supplied with the NOS kit. It just doesn't make any sense to me that the computer would be shocked 1000 rpm AFTER the initial hit. I would thinik the ECU would freak out as soon as the nitrous hit. Can you post your dyno sheet if you can please. Thanks for the info!!

willrace4food,
My only mods are in my sig. Just the longtubes/offroad H and the spray.
 

·
Registered
Joined
·
1,462 Posts
That is really weird. My friend kinda had the same problem. Although he fixed his by switching to a larger aftermarket fuel pump. It seems like the computer is affecting the fuel output. Have you checked all your connections? Does this dry kit use a vacumm connection to adjust for fuel?
 

·
Registered
Joined
·
1,980 Posts
Was that on a 150 shot or 125? I would go with a bigger intank pump, the stock pump even with the inline i dont think can push the fuel for a 150. I had a similar problem. Put in a 255 lph and solved the problem. Also where is your nozzle spraying into, before or after the MAF?
 

·
Registered
Joined
·
568 Posts
Discussion Starter #10
Thanx for the replies guys. Yes the kit uses a vacuum connection willrace4food. I checked all the connections and the pump works perfect.

Juiced46, i'm spraying a 150 shot after the mass air. Whag intake pump did you go with and did you keep the inline pump with it?
 

·
Registered
Joined
·
1,980 Posts
My kit is a wet kit and doesnt come with any pump. I beleive yours came with the inline correct? I am using a Walbro 255 lph pump with no inline. In your case since you have the inline also, i would use a 255 and an inline just to be safe, you already have it so you might as well use it. Im still trying to figure out why you have that spike though, very odd.
 

·
Registered
Joined
·
1,462 Posts
Go for the GSS 342 high pressure 255lph intank from Walbro. www.jdsperformance.com has it for around $109. Cheap insurance. If that doesn't fix it, then you have issues. Your spraying a 150 you should at least be making that much, not 111 rwhp.
 

·
Registered
Joined
·
180 Posts
Uh Oh slobra281, you have the same set up as I do. I think I better go and get dynoed and A/F ration.
 

·
Registered
Joined
·
568 Posts
Discussion Starter #16
slosvt said:
Do you have a bottle warmer and N2O pressure guage? If not then you probly didnt get the best hit possible. What about a purge? Also a newer bottle will hit harder than one that has been used.
Bottle pressure was at 1100 psi and yes I have a warmer. Trust me, the hit was pretty good. ;) I have no purge yet and the I've had the kit for about 6 months. Its still pretty new. I'll definitely buy that in tank and head back to the dyno.
 

·
Registered
Joined
·
1,949 Posts
Get the intank pump, that should solve your problem.

Last year when I was running the 125 shot on the stock pump, I had someone watch my FP gauge and they said when I first hit the button I dropped FP right after it started to increase but after that it went right where it was supposed to.
It hapened so fast he was not able to see excatly how much of a pressure drop there was.

I bought a bigger pump (Walbro 255 High Pressure) to fix the problem.

Eric
 

·
Registered
Joined
·
439 Posts
lean or rich?

Maybe I'm dumb, but isn't that a rich spike? You started to go lean (~13) with the appropiate bump in HP and then comes the spike to 17.5. Isn't that rich?
 

·
Registered
Joined
·
439 Posts
lean

Yep, I got it backwards. Please disregard last post:eek:
 

·
Registered
Joined
·
362 Posts
I HAVE the walbor GSS342 :mad:. Thats not the problem, its gotta be in the computer. I'm running the NOS 5115, I'll post my dyno as soon as I scan it. BAP is on order.

Neal
 
1 - 20 of 20 Posts
Top