Ford Mustang Forums banner

1 - 20 of 36 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Have been having an odd misfiring at 2500-3000rpms when accelerating at roughly 1/8 throttle. Can give it more gas or let out and it stops misfiring. Did some data logging and found that the MAF counts go crazy when the misfiring takes place. Was wondering what everyone thinks the causes of this could be? I'm not sure if it's a bad MAF or if could be something else? I can provide more data logs or information if needed. I'll add pictures of the intake setup, because I'm not sure if the bypass could be causing some kind of interference to the MAF.

SCT-BA2600 MAF (Draw Through)
CX Racing Intercooler
Vortech MaxFlo BPV

First datalog is slowly accelerating in 4th. The second is at idle and then holding the revs at 2,000 rpms.
 

Attachments

·
Registered
Joined
·
22,227 Posts
THE idle one is at operating temp?

Can you do one with the misfire?

Also do one at idle, and snap to wot a few time, we want to see the 02 reaction

Log rpm
 

·
Registered
Joined
·
40 Posts
Discussion Starter #7
I'll data log another idle file at operating temp and one snapping the throttle at WOT.

The data log in my first post where I have the car in 4th gear shows the misfire. When the counts go crazy is the misfire, but the MAF counts were all I data logged. I'll try to data log the misfire again with more PIDS. What all would you like to see for the misfire?
 

·
Registered
Joined
·
22,227 Posts
Redo with both upstreams

look at first chart

Both your long terms are pegged in adding fuel

The ecm thinks you are lean......???
 

·
Registered
Joined
·
40 Posts
Discussion Starter #11
I'm gonna perform a smoke test this weekend to see if I can track down any possible vacuum leaks. The car will see -18in.Hg in vacuum during a cold start. Once the car is up to temp the vacuum varies between -14 and -13. I have MHS stage 3 blower cams, so I'm assuming that amount of vacuum is correct for those particular profiles. They've since come out with a second generation of camshafts and I no longer remember the cam specs.

I'll also redo the data logs that were missing the b2s1 o2 readings this weekend.

This is something I should have mentioned in my first post, but I did pull two codes on the car a couple of months ago that indicate it being lean (P1132 and P1152). I had drove the car for months off and on before those codes finally came up. I deleted the codes to see if they would come back when I first got them and they haven't popped back up yet.
 

·
Registered
Joined
·
22,227 Posts
you probably still have a p1000

so the codes will probably be pending.....

dont need codes when you see trims like that


i think you have maf issues........

can you log DC of the frequency?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #13
Could I log the DC as a PID? Or would I need to splice into the pigtail and use a multimeter?

Also I tried unplugging the MAF and the misfire/hesitation goes away when I try to hold the revs around 2,000.

I still need to datalog the misfire while driving, so I'll upload that here later today.
 

Attachments

·
Registered
Joined
·
22,227 Posts
one more

with the same PIDS as the last one

hot engine

from idle, to 1000rpm hold for 5 sec, then 2000rpm then 3000rpm

hold those rpms for a min of 5 seconds
 

·
Registered
Joined
·
40 Posts
Discussion Starter #18
I’m thinking bad maf. This is my first time with data logging, so hopefully I’m not missing something that you are seeing
 
1 - 20 of 36 Posts
Top