Ford Mustang Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
went to track last night and run a 11:156 at 121.44 mph with a 1.616 60 ft. Do the number seem right or is something off. i thought 121 mph was a 10:90 pass. the car seemed to just squat in the rear then run. would be happy to get it in the 10's.
 

·
Registered
Joined
·
361 Posts
My times are in my sig. Your times look good to me I would think if you get your 60fts in the 1.5 range you can get your 10.9
What tire you running and your set up?
 

·
Registered
Joined
·
7,198 Posts
Not out of line...

I went 11.33 at 126 with a 1.73 60'

Yes, I know I need tires....
 

·
Registered
Joined
·
129 Posts
Discussion Starter #4
i got a 347 carbed sb with a c4 trans/4500 stall and 456 gears. running on 28x9 slicks. i had a stock 302 with a 125 shot and 373 gears and had a 1:54 60ft so for the 60ft to go slower is confussing me. i have 90/10 front struts and 50/50 rear shocks with adjustable uppers. maybe i should get some adjustable rear shocks to controll the squating? it use to pull the tires up now it doesn't.
 

·
Registered
Joined
·
630 Posts
Like stated before, that is easily a 10.9x pass with a better 60'. Whats the tire/suspension setup and how much air are you running in the rears?
 

·
Registered
Joined
·
129 Posts
Discussion Starter #7
i got 28x9 slicks at 13 lbs of pressure. the tires were not spinning. the car just seemed lazy off the line. the motor run good with no spit or sputter. my friend said the car looked to squart alot. the car weigths 3045 with me in it.
 

·
Registered
Joined
·
3,979 Posts
Yeah, either you are spinning, or you've got something off in the tune.
I went [email protected] with a 1.53 sixty foot, EFI 347 with a 4200 stall, 3.73 gears, 28x9 tire, 3050 lbs race weight. I ran a [email protected] on a 75 shot throttling the car past the 1000' mark because I was out of converter/gear on the nitrous. It went a 1.48 sixty foot on that 10.70 pass.
 

·
Premium Member
Joined
·
1,547 Posts
set-up in my sig..but i know i have a crap carb....so maybe something is off on your tune
 

·
Registered
Joined
·
2,484 Posts
With your 60' I think you are right on the mark.
 

·
Registered
Joined
·
773 Posts
Same here, look at sig ...What is your RPM going through the traps?
 

·
Registered
Joined
·
418 Posts
How high is your front end extending? Is it coming up fast and going down fast? It needs to rise slow and fall slow..If the front end it rising fast..your using torque to raise the front end instead of moving the car. Slow the rise of the front end. Also is the rear squatting and staying down or bouncing back up? I know if you have to soft of springs will cause the rear end to unload if you dont have the power to keep the rear squatted. It should squat and stay squatted for the at least first 60'-100'.
 

·
Registered
Joined
·
7,142 Posts
Last years setup went 11.503 @121.40 with a 1.63 short time. 3350lb race weight.
 

·
Registered
Joined
·
1,109 Posts
i dont think its that light, its a full weight, power windows, power seats, full interior, all steel except the hood, and a roll bar hoop and rear down bars, no door bars, and my 260lb ass in it

its not stripped at all, it also needs a bigger convertor and different gear, need another 1k in stall speed and a 4.10 gear, currently crossing the traps at just under 5300, shift at 6700
 
1 - 20 of 24 Posts
Top