Ford Mustang Forums banner

1 - 20 of 42 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
My ride is alot slower than it should be. Maybe some of you could chime in and give me some advice or pointers?

89 LX Convertible. Full weight caged AOD car, full interior, only weight reduction is swaybar/heat/air conditioning is gone. Bone stock 90,000 bottom end, box stock AFR 165's. Stock Cobra intake, F-cam, 65mm tbody, 73mm C&L MAF, 190 fuel pump, 24 lb injectors. Aod has an Edge 3200 non lockup converter, good valvebody, and i have 3:55 gears. Weld draglites skinnies/mickey thompson 275/50/15 drag radials. Lakewood shocks/struts, 4 banger springs, Mac control arms. The car also has a 6pt rollcage. BBK shorties, h-pipe, flows, timing at 12 degrees, air fuel ratio was 12.2:1 - 13.0:1 at WOT. I shift at 6000 rpm.
Heres my crappy timeslip:
60ft......1.88 (didnt spin at all)
330ft.....5.53
1/8........8.60 @ 79.9
1/4........13.56 @ 97.37

Sorry for the long post but if anyone has any ideas let me know!
Thanks!
 

·
Registered
Joined
·
3,711 Posts
drop fp 3-4 pounds, try some more timing and 4.10s.

how are you taking off? i get my best results holding the brake at idle and punching it when i'm ready to go.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #3
Im just footbraking it like you. I was hoping to see at least a 13.0 with this combo. I had 4.10's in it until i put nitrous on, the i ran out of gear when spraying so i switched to 3:55's. Even with the not so great gears, shouldnt i be trapping at least 104 with AFR heads/cam/intake?
 

·
Registered
Joined
·
5,933 Posts
Hmm maybe tune it. Not sure had those times with a stock 302. Did u go to beechbend?
 

·
Registered
Joined
·
307 Posts
Discussion Starter #7
No i did not go to beech bend. I know my MPH is low, i just cant seem to figure out why. The car runs and drives great with no hesitaions and throttle response is awesome. I self tuned by adjusting the air/fuel ratio, timing and fuel pressure.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #8
heres a puzzling question. I have always had an open port on the back of the cobra intake. When i try to cap off the vacuum leak, it wont stay running. The idle surges and the car will die. Maybe a bad vacuum leak is screwing up something somewhere? Who knows....
 

·
Registered
Joined
·
307 Posts
Discussion Starter #9
Someone please talk me out of selling it and buying an LS1 lol.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #11
I know haha. I cant figure out how to keep it running though.
 

·
Registered
Joined
·
219 Posts
Someone please talk me out of selling it and buying an LS1 lol.
Changing spark plugs on ls1's is a nasty job. Uhh.. the cars are cheap but the aftermarket is anything but lol.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #14
Yeah true, but i like to drive to the around town and to the track and have to have overdrive. I think weight is the biggest problem.
 

·
Registered
Joined
·
57 Posts
Yeah true, but i like to drive to the around town and to the track and have to have overdrive. I think weight is the biggest problem.
Yeah it's tough for some to break from an AOD for that reason. C-4 would save some weight though, and wont rob as much power. If your not driving on the highway that much they're not bad. Gears will def. help though.
 

·
Registered
Joined
·
1,658 Posts
Track heat intake, 70mm TB, 75mm MAF and a lil weight reduction IMO!
 

·
Registered
Joined
·
509 Posts
Is the port that is open on your intake a large one? I agree that you need to plug that up or connect it to where its supposed to go. The only ports I know of are the ones coming off of the bottom of the intake and the EGR port...is it one of those?
 

·
Registered
Joined
·
307 Posts
Discussion Starter #19
Thanks for the replies.
Im not sure what port it is right now, i can check later if needed. I have a feeling its for smog possibly? I got rid of all my smog crap a while ago.
So, 3:73's, bigger MAF/Tbody maybe intake and tweaking and i should be around a 13.0 im hoping. What do you guys think about Longtubes and an x-pipe?
 

·
Registered
Joined
·
307 Posts
Discussion Starter #20
Oh yeah, i forgot to mention it was about 85 degrees and very humid out. Also, i think i have a bad fuel pressure regulator because the fuel pressure keeps changing psi on its own.
 
1 - 20 of 42 Posts
Top