Ford Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
Recently added TFS 11R 190 heads to my 80k mile stock shortblock with Paxton novi 1220 blower. I kept the stock cam and I am running SD 80 injectors, Performer 5.0 intake, and tuning with Megasquirt. Running felpro 9333pt1 head gaskets with ARP studs. Running felpro 1262S3 intake gasket Got the car tuned with 8" crank and 3.8 blower pulley and all was well and I was seeing 8 pounds at 6000 rpm. Swapped blower pulley for 3.15 pulley and took car out to further tune. Got into boost a few times and afr was correct throughout the range. Saw 12 pounds of boost at one point and car was pulling hard. Getting back on the gas after a decal I noticed a puff of smoke in my rear view mirror, hmmmmmm........that doesn't look right. Continued cruising and saw the smoke again. Temperature gauge never got hot, stayed in normal location. I got the car home and popped the hood. I saw oil on the passenger valve cover under the breather. I pulled the breather and the crankcase was under some pressure and puffing out some "vapors". Left the car to cool off and returned a few hours later. Checked radiator and was down on coolant significantly, now I am second guessing myself as to whether I was burning coolant or oil? I checked oil level and it was perfect, with no evidence of coolant on dipstick. I am hoping I am simply burning coolant due to a intake gasket failure (I never retorqued it), versus a head gasket failure. I pulled all of the spark plugs and found that 1,2,5,6,8 looked nice and clean. Plugs 3,4,7 looked like they were fouled by oil? I took pics for your review and I also shot video of the exhaust smoke and the valve cover puffing. Any recommendations on troubleshooting or thoughts are welcome.

Videos below



I am
 

Attachments

·
Registered
Joined
·
200 Posts
Discussion Starter #3
According to yesterdays datalog:

I saw 28 degrees at 0 vacuum/0 boost

23.2 degrees at 10.5 pounds of boost w AFR of 11.6
 

·
Registered
Joined
·
200 Posts
Discussion Starter #5
Ordering leak down tester today.

Only thing that has me confused on the theory that rings let go is the loss of coolant.
 

·
Registered
Joined
·
21,854 Posts
Is that engine up to operating temp?

there is a huge clue..........when you revved it, the smoke from the, CARB breather, stopped.

manifold pressure went up, smoke slowed or stopped......mmmhhhe?

How are you evacuating the crankcase??
 

·
Registered
Joined
·
200 Posts
Discussion Starter #7
Is that engine up to operating temp?

there is a huge clue..........when you revved it, the smoke from the, CARB breather, stopped.

manifold pressure went up, smoke slowed or stopped......mmmhhhe?

How are you evacuating the crankcase??
Engine is at operating temp during videos.

Running a pcv valve with breather at back of lower intake and a breather on passenger valve cover.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #9
No vacuum to the pcv.

Just a pcv valve with a breather on it in the rear lower intake.

Breather on passenger side valve cover.

No active system as far as evacuating crankcase vapors, all passive.
 

·
Registered
Joined
·
21,854 Posts
the PCV valve cannot work, that way

You need to draw CC vapors into the intake, and fresh metered air must be allowed in to replace it

but, I believe that will be need to be thought out, for your next engine

time for a compression and leak down test......
 

·
Registered
Joined
·
410 Posts
hopefully its just the 9333's giving up. not a big fan of them with boost even though other guys on here like them. good luck with it and let us know what you find.
 
1 - 11 of 11 Posts
Top