Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I picked up a '95 convertible to work on with my daughter. The top doesn't go up or down, but the emergency brake light comes on in the dash, and when pressing the button I get clicks from the relays. I also pulled the plug going to the pump (two prong, grey connector) and can measure 12V on the relay side of it when pressing the button. To me this looks like a a bad pump, but I wanted to check with you guys in case there's something else that could be going wrong here that I'm over-looking.
 

·
Registered
Joined
·
5,519 Posts
My 01 developed a leak in one of the rams and eventually lost all the fluid. However, the pump still "pumped" with the switch. It's also possible the PO lost the fluid and then burned up the pump trying to raise the top (they are very heavy and resist manual effort). Swapping pumps is not hard but it does take patience. I think you're going to need to take out the rear seats and remove the pump for diagnosis.
 

·
Registered
Joined
·
23,232 Posts
I picked up a '95 convertible to work on with my daughter. The top doesn't go up or down, but the emergency brake light comes on in the dash, and when pressing the button I get clicks from the relays. I also pulled the plug going to the pump (two prong, grey connector) and can measure 12V on the relay side of it when pressing the button. To me this looks like a a bad pump, but I wanted to check with you guys in case there's something else that could be going wrong here that I'm over-looking.
you have 12volts across the pump?

where is the ground lead?
 
1 - 3 of 3 Posts
Top