Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
93 5.0 When I turn my key on I hear clicking under the hood it sounds like relay chatter. I re grounded the grounds next to the battery and that made it ok for a few starts. The problem is back no matter how I ground the grounds by the battery I still hear clicking. With the fuel pump relay is in the clicking is real loud and the pump runs continuous. When I unplug I hear clicking from somewhere else but I can't pin point it. As the clicking starts the check engine light flickers.
Dose anyone have a diagram of grounds ?
Has anyone had this problem before ?
What relays are under the hood?
Are there any computers or modules under the hood that could make this noise?
Thanks
 

·
Registered
Joined
·
23,245 Posts
key can be in 'run' or 'crank',

what are you talking about?

you need a good wiring diagram, its called an EVTM, or look at the sticky.

so you can test circuits.........

is this a stock ecm, no chip?

try a code reader, and see what happens, but a flickering CEL, is usually an issue with a poor ECM ground, or a 5volt ref short to ground......

you are going to have fun now......
 

·
Registered
Joined
·
23,245 Posts
comm circuit for all sensors
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Unplugged distributed and some of the noise went away the remaining noise sounds like the injectors pulsing.
Is the computer's only ground on the inner fender next to the battery?
Could not find sticky with wire diagram where is a good source to get a good wire diagram?
Suspect a bad computer but I don't know what pins to check to verify good source power and ground
Car has been sitting before I got it and it is a covertable I think moisture has been in the car since I had to replace all 4 power window motors and both lock solenoids
The dimmer switch is buggy ( possibly corroded ) I wonder if the ignition switch ( if corroded) could cause this flicker?
Can I jump power to the computer to eliminate the chance of the ignition switch causing this problem ?
 

·
Registered
Joined
·
23,245 Posts
evtm

bbb industries

for diagrams
 
1 - 6 of 6 Posts
Top