Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I'm having an issue with the car charging. I believe this is a different issue than your standard "bad alternator".

Car:
2002 GT
SCT 4-Bank Tuner
CAI

• When the car is idling no charging light.
• When the engine is around 1500-3000 RPM the charging/battery light will flicker; it never stays on totally. When the headlights are on, it seems worse and I can see through the dimming of the dash and headlights that charging is varying (gets dim, bright, dim).
• Above 3000 RPM the light stays off
• Both the alternator and battery have been checked multiple times. The tester says the alternator is putting out 14.7 during charging (was tested on the car and off the car, passed both tests)
• Problem still occurs with a new alternator and serpentine belt, no effect on behavior.
• I've double checked connections on the battery, alternator and fuse box, everything is tight. The control harness in the alternator is also fully plugged in.
 

·
Registered
Joined
·
22,414 Posts
it has passed visual check

now you have to perform elec test

start at alt and go to battery and find the voltage drop across each conductor and connection
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Figured out the problem. It's something with the connector that plugs into the alternator. I moved it and the car quit charging entirely. Moved it again and it came back. Apparently, the battery bulb has burned out now too because the light didn't come on when the alternator wasn't charging (battery gauge was reading just about 0)
 
1 - 3 of 3 Posts
Top