Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter #1
Car is untuned see sig for details I haven't stepped on the car for a while decicded to do it on the way home in 2nd got up to 5400 rpm then started to studder. I got out of it immediately the only thing that I can think of is fuel pressure I have it set at 37psi timing at 8 not locked out. Tried locking the timing at 18 but computer still advances it. Maybe the bov opening to soon? I did bump it up to 8psi.
 

·
Registered
Joined
·
3,221 Posts
What plugs are you running? What is your ignition setup? I had the same thing when I was running gt40p's. The fix was a simple switch to non-projected tip spark plugs.
 

·
Registered
Joined
·
268 Posts
Discussion Starter #3
I'm running autolite 103 gapped at 32 (coppers)
Stock ignition just some accel spark wires
 

·
Registered
Joined
·
295 Posts
Gap them tighter....025...Also you could be lean or too much advanced especially if you have no way to pull timing....
 

·
Registered
Joined
·
268 Posts
Discussion Starter #5
Gap them tighter....025...Also you could be lean or too much advanced especially if you have no way to pull timing....
Ill see what milhouse suggest on type of plug ill gap it around 25 and bump my pressure back up to 40
 

·
Registered
Joined
·
268 Posts
Discussion Starter #8
Thanks fellas. my fuel pressure gauge is busted! Ill see if I can grab a new one. I'm gonna get those sparkplugs done hopefully this weekend
 
1 - 8 of 8 Posts
Top